FS#1532 - USB plug not recognized after debug menue

Attached to Project: Rockbox
Opened by Anonymous Submitter - Sunday, 20 July 2003, 15:12 GMT
Last edited by Daniel Stenberg (bagder) - Friday, 05 December 2003, 09:25 GMT
Task Type Bugs
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No



I entered the debug menue today, looking what can
be found in there. I pluged my USB cable into the PC
and into the Archos while still being within the HW
Info feature.

The Archos did not recognize that I plugged the
cable into the unit. It even did not recognized the
plugged-in cable after I left the menue and headed
back to main directory view. I had to pull the cable
out and plug it in again to go into USB mode.

I have an Archos Recorder 20

Rom 2.00 (daily build 20030720)
Mask 0x0302
USB: positive
ATA: 0x200
FR: negative
Flash: M=BF D=D6

Maik Schmidt
This task depends upon

Closed by  Daniel Stenberg (bagder)
Friday, 05 December 2003, 09:25 GMT
Reason for closing:  Wont Fix
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 27 August 2003, 14:49 GMT

The debug menus are *debug menus*. They don't behave like
the other menus and are not to be trusted. As it says: keep
out. The USB detection is simply not active in the debug menus.
Comment by Mike Holden (mikeholden) - Thursday, 28 August 2003, 08:46 GMT

I will say that I believe this is not a bug, and is the intended
action. It is useful sometimes to be able to see the status of
the unit when the USB is plugged in.

Please DON'T "fix" this!