FS#1793 - resume fails when playback is stopped before powering off

Attached to Project: Rockbox
Opened by Anonymous Submitter - Friday, 14 November 2003, 14:11 GMT
Last edited by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 26 May 2004, 05:37 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


I'm using a JBR20, Firmware 1.28, Rockbox cvs-030830
loaded from disk, resume is set to "Ask".

When I play a few songs (mostly from a directory,
because this bug makes using long playlists rather less
useful), and then press the OFF button to stop
playback, then after playback has stopped and I'm back
at the directory screen, immediately press and hold the
OFF button, the unit shuts down, as it should. When I
start it up again by pressing ON, in about 1 of three
cases (on average), Rockbox does *not* present me with
the Resume question.

OTOH, if I press and hold OFF during playback (which
the JBR_HELP.TXT discourages!), the unit shuts down as
well, and resume works reliably the next time the unit
is powered on.

Daniel Gudlat
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Wednesday, 26 May 2004, 05:37 GMT
Reason for closing:  Out of Date
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 09 April 2004, 23:30 GMT

Can you please try with the latest daily build and tell me
if it works better. I believe this bug is fixed.
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 26 May 2004, 05:37 GMT

No reply. I'm closing this report.