Rockbox

Tasklist

FS#2124 - Instrument Tuner

Attached to Project: Rockbox
Opened by thlorenz (thlorenz) - Monday, 05 April 2004, 04:30 GMT
Last edited by Marc Guay (Marc_Guay) - Tuesday, 02 December 2008, 00:29 GMT
Task Type Feature Requests
Category Plugins
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

A simple program allowing to tune an instrument via the
built in microphone or the line in jack. I don't know if
that would be possible. The app would have to analyse
the frequency of the input signal amd I don't know if
you can do that.
Otherwise an app just sounding a 440HZ signal would be
of help for tuning.
Closed by  Björn Stenberg (zagor)
Tuesday, 02 December 2008, 00:29 GMT
Reason for closing:  Invalid
Additional comments about closing:  Closing all feature requests.
Comment by roguefire (roguefire) - Monday, 19 April 2004, 06:19 GMT

yah that would be really helpful. i hope somone does it. i don't
know how, i don't know much at all. but if someone who knows
how reads this, PLEASE MAKE IT PLEASE PLEASE PLEASE, i
think it would be reaaaly kool. ty
Comment by Daniel Stenberg (bagder) - Friday, 10 September 2004, 21:43 GMT

Why not just get someone to produce a long high-quality mp3
with a 440Hz tone?
Comment by Open Mindworks (ddp-project) - Saturday, 11 February 2006, 16:47 GMT

just do a quick pitch-finding (use Audacity's algorithm).
compare it to 440Hz (or any other reference frequency) and
12 tones (or any other...): 2_log(freq/440)*12 = number of
half tones from A. Show which not you are near to and how
much you are away from it and your tuner is done!
It would be fun to use the leds on the device (iRiver has a
red and a green one). When the result is (almost) a whole
number, the green light must show, otherwise use the red light.
Comment by Step Han (fuelnatchos) - Saturday, 22 July 2006, 02:23 GMT
It would be simple, I guess, to get input from the jack, byte by byte, and then show the output signal on the screen (oscilloscope). If we can set the output width corresponding to the note we want (calculating how many data we get per second and 440Hz, finding the wave length), we would get a nice graphical wave that tends to go to the right if it's too long (flat), and to the left if it's too short (sharp). The user could select the note he wants to tune, and then it would be easy to tune it based on what he sees! It would certainly be more simple than programming an algorithm that tries to guess what note we want to get...
(I hope someone got what I'm trying to say here...)
Comment by Nils Wallménius (nls) - Wednesday, 16 August 2006, 21:57 GMT
http://www.rockbox.org/tracker/task/5031 was closed as a duplicate of this request but if anyone is interested in making this it had some useful comment(s)
Comment by Eivind Ødegård (meinmycell) - Monday, 12 February 2007, 21:16 GMT
One method for instrument tuners on computerish equipment is Schmitt triggering, which is a method of "counting the number of triggerings between two trigger levels in a certain amount of time", according to http://www.geocities.com/harpin_floh/kguitune_page.html. The other method is FFT, which supposedly uses more CPU power.

My (Ubuntu) system lists two tuner programs:

- gtkguitune, see web address above
- lingot, http://www.nongnu.org/lingot

Maybe it would be possible to borrow some code from one or both of these projects? I don't know the first thing about coding, so I would only be in the way. But I'll help out in other ways if I can. I'm interested in seeing this happen.

Of course, musicians could record a few seconds of a 440 Hz sine wave to use their rockboxed devices as tuners, but a real, chromatic tuner plugin would be such a wickedly cool thing to have... Along with a multitrack recorder, a tone + white noise generator and a guitar amp simulator... (see other featuritis requests for these). Rock on!
Comment by Jake (Zombieplasticclock) - Friday, 20 April 2007, 18:04 GMT
Oh man... That would be the coolest! I wish I could help make this, this would really come in handy for me...
Someone PLease make it!
Comment by mihbar (mih140) - Monday, 25 June 2007, 15:17 GMT
It would be a wonderfuf feature ! for lute, oboe, clarinet, bassoon, horn, ...., violin, viola, cello, ... , guitar, luth, theorbe, ...players

I think iriver hardware is ok. some thing like the Vu-Meter plug-in , with a tuning screan instead.
Some programs allready exist for PalmOs, GSM phones, Linux, ...
some projects here : http://freshmeat.net/search?q=tuner

Please, please make it!!
Comment by harry tu (bookshare) - Wednesday, 15 August 2007, 00:41 GMT
Here is a file with a 440 hz tone.
   440.WMA (69.6 KiB)
Comment by mihbar (mih140) - Saturday, 18 August 2007, 15:18 GMT
Nice!
but it can't replace a chromatic tuner !
In orchestra tune is 442Hz, baroque music is often 415hz 435hz 438hz ...
When you want to quikly verify a note (when playing) a real tme measure with --> or <-- is GREAT
on 7th chord, you have to play not the mathematical note, but droping 1/3 semiton (or -32 cents)
A chromatic tuner is an essential tool !!
Shame i can code :-(
Thanks to our dev team !!
Comment by bodymind (bodymind) - Tuesday, 11 November 2008, 21:46 GMT
Take a look in here... there is some GPL code in c :)
when i get some more time i maybe try to do it.. 8)

http://www.koders.com/c/fid18FFFEFA86DE735EC24DF93F60C2370A6CC43FBD.aspx?s=tuner+guitar#L1

Loading...