FS#2454 - Recording generates bad / corrupt mp3 files

Attached to Project: Rockbox
Opened by Anonymous Submitter - Saturday, 26 February 2005, 11:11 GMT
Last edited by Gorgon5 (gorgon5) - Thursday, 29 September 2005, 01:13 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I am using an Archos Jukebox Recorder 20 with Rockbox
2.4(latest version, flashed). Some days ago I recorded
an opera transmission by a local radiostation. The
recording time was about 3 hours, the recorded data
were distributed to 7 files. To achieve the file
splitting I used during the recording session the "F3"
key at appropriate times. Everything seemed to be fine
- but listening to the files ended with a disappointing
The first three recorded files are okay, but the
following four ones are bad or corrupted.

The "features" of the bad files:
- On the PC mp3 players(irfanview(plugin), BSPlayerPro)
reject to open these files,
- MP3DirectCut loads the files. But there are "gaps" in
the graphical representation of the file content and
the program is not able to play or to navigate within
the files
- the jukebox is able to play the files, but displays
strange information about the recording: while for all
the good files the WPS indicates as "recording quality"
192 kbit the WPS shows for the bad files 48, 64, 40 or
192 kbit.
- the jukebox indicates only for the first generated
file "id3v3.2", for all others the WPS says "noid3".

Here my recording settings:
Quality=7, Frequency=44,1 khz, Source=line-in,
Channels=stereo, Independent frames=yes,
, Time-split 04:00, Prerecord time Off

I did some rockbox(disk-) checks with Windows 2000
tools - no errors found.
Eventually is there a relationship to the bugs "937100"
and "857468".

I hope the brave rockbox team will fix this bug. If it
is of interest I could provide the bad files.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Thursday, 02 March 2006, 10:37 GMT
Reason for closing:  Out of Date
Additional comments about closing:  If this is still a problem with a recent build, open a new bug report.
Comment by Anonymous Submitter - Saturday, 26 February 2005, 18:48 GMT

I've made tests on the bad files:
- vbrfix loads and then cancels processing because "in frame
3 mp3 version changes".
- mp3utility loads and stops processing because "Sync error
reading frame header 2 expected at byte 989..."

I could provide the log files of the tests.
Comment by Anonymous Submitter - Tuesday, 22 March 2005, 15:11 GMT

I get exactly the same symptoms. I've been recording my
vinyl albums, so no single recording is more than around
20-25 minutes. I'm seeing about 1 in 10 (estimate) with the
described problem. I, too, have been using MP3DirectCut to
split the files into individual tracks, and see the same
gaps in the audio representation.

Same recording settings, but no time split.
Comment by Anonymous Submitter - Monday, 18 April 2005, 16:36 GMT

Appears that I have had a similar problem. The recording
chatters when listening to it on the jukebox or through Media
Player. MP3DirectCut shows gaps. Eventually looses itself
for the remainder of the playback. Running a full surface
scan and fix (chkdsk) on it through Windows 2000 seems to
have fixed it, or at least it hasn't reoccured yet.

So, in my case, it appears that the gaps are caused by bad
disk sectors. I can "recover" the recording by running
MP3Fixer and then MP3Gain on the file. The recover file will
contains some "noise" where the gaps were (like pops etc)
but at least I can hear the rest of what I recorded.
Comment by Anonymous Submitter - Wednesday, 04 May 2005, 06:39 GMT

I had again the bad experience with non-usable recording
results. I recorded this time with Quality = 6(instead of 7)
in a long session. The two generated files((length ca. 207
MB / 107 MB) are not to use. So the quality level is not the

I went back to Rockbox VERSION 2.2 and could twice
SUCESSFULLY record (similar recording length, Quality = 7
and all the other parameters as described in the bugreport).
I guess somebody has introduced the NON USABLE recording
function IN VERSION 2.3 or 2.4.
Comment by Anonymous Submitter - Tuesday, 28 June 2005, 09:31 GMT

Rockbox Version 2.2 generates also bad, unusable files !
Comment by Anonymous Submitter - Friday, 05 August 2005, 21:50 GMT

Following up my comment of Mar 22. Been doing some more
vinyl recording, and seeing the same problem occasionally.
Further experimentation show that the recording has the
MP3DirectCut "gaps" from about 17m17s into the file - total
length is shown as about 18m55s. Archos plays the file all
the way to the end, but a glitch occurs in the audio at
about 17m12s. MP3DirectCut and WinAmp both stop dead at the
problem area.

Running VBRfix on the Archos, shows the file to now be
17m12s in length (ie, to where the glitch occurs), but still
seems to hold the entire recording. WinAmp and MP3DC still
barf at the same point in the file (musically), but the time
is now shown as about 15m48s.

Hope this is helpful. I have kept the bad file (26.5MB) in
case it's of use to anyone.
Comment by Anonymous Submitter - Wednesday, 24 August 2005, 11:12 GMT

Again bad recording experience. This time with Rockbox 2.1.
The resulting file(more then 200 MB) can not be used with a
mp3 player(like Irfan) or mp3directcut. EVEN Rockbox itsself
cannot play the file. Treatment with "vbrfix" does not
change anything.
After a treatment with "mp3fixer" the file can be played.
There are some minor artefacts("clicks") - but its not clear
wehter these are produced by the recording process or
mp3fixer. "mp3fixer" "says" that some faulty frames have
been eliminated from the original file.

I hope that with a new version of Rockbox the "recording
problems" can be fixed, the software in the actual state is
not usable.
Comment by Anonymous Submitter - Sunday, 18 September 2005, 20:21 GMT

I just recorded almost 5 hours live concert using Rockbox
2.4 on an Archos Recorder 20. In the middle of the file -
when playing on the Archos, there was dropouts in the file.
This happened at a rate of maybe 2-5 Hz (estimated).

I used mp3fixer (unix version) on the file and it solved the

I can provide the file.

BR Peter
Comment by Gorgon5 (gorgon5) - Thursday, 29 September 2005, 01:13 GMT

I, too, have had a very annoying recording problem since, I
think, version 2.3. 2.2 was fine, but now any recordings
over around 8 minutes will show a length of 00:02, and
trying to fast-forward will make it skip to the next track.
Just tried version 2.5 and bug is still present. Anyone
know where I can get the 2.2 firmware?