Rockbox

Tasklist

FS#2653 - added one-click-to-insert functionality in file tree

Attached to Project: Rockbox
Opened by rubberglove (rubberglove) - Sunday, 28 August 2005, 00:59 GMT
Last edited by Bryan Childs (GodEater) - Thursday, 24 December 2009, 07:28 GMT
Task Type Patches
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

that's it. for iriver (i think) click the joystick
(select) to insert the selected
track/directory/playlist to the current playlist (or
create a new one if none) seems to work, use with
caution, enjoy.

This task depends upon

Closed by  Bryan Childs (GodEater)
Thursday, 24 December 2009, 07:28 GMT
Reason for closing:  Rejected
Additional comments about closing:  This is changing the basic behaviour of the select button in the file viewer, and is never likely to be accepted into the rockbox core.
Comment by Anonymous Submitter - Tuesday, 01 November 2005, 09:47 GMT

an update that works with recent builds (2005-10-31) can be
found here: http://forums.rockbox.org/index.php?
action=dlattach;topic=1617.0;id=249
Comment by Matthias Mohr (aka Massa) (mmohr) - Saturday, 11 March 2006, 21:08 GMT
Here is roolku's patch updated for today's CVS.

I hope the patch lasts until it finally find its way into the CVS ;)
Comment by Matthias Mohr (aka Massa) (mmohr) - Wednesday, 29 March 2006, 08:14 GMT
Does no longer work in latest CVS versions - needs some research to make it work again...
Comment by Martin Scarratt (mmmm-) - Sunday, 27 August 2006, 11:44 GMT
Here's an updated version...
Comment by Martin Scarratt (mmmm-) - Monday, 28 August 2006, 11:01 GMT
Fixed remote buttons: record on h1xx remote, navi on h3xx remote
Comment by Martin Scarratt (mmmm-) - Monday, 18 September 2006, 18:54 GMT
This patch isnt for the H3xx alone so as there isn't an option for iriver h1xx/3xx I'll put it back to 'all targets' It is also as easy as putting the ACTION_TREE_INSERT button def into the appropriate keymap file to extend this functionality to any other target and everybody is invited to do so...
Comment by Martin Scarratt (mmmm-) - Saturday, 11 November 2006, 11:59 GMT
Update to latest CVS
Comment by tim goff (goffa) - Saturday, 11 November 2006, 21:50 GMT
Here's my attempt at making the x5 work. I didn't touch the remote code as i don't have a remote. Seems to work fine on my player though.

First patch ever, so watch out. :)
Comment by Max Weninger (maxwen) - Monday, 13 November 2006, 23:40 GMT
Fixed patch and added all possible playlist options to the menu
Comment by Max Weninger (maxwen) - Wednesday, 22 November 2006, 18:02 GMT
Added support for id3 mode
Comment by Max Weninger (maxwen) - Friday, 24 November 2006, 22:00 GMT
Fixed wrong return values from one_play_click
Comment by tim goff (goffa) - Saturday, 30 December 2006, 08:14 GMT
works on the gigabeat now... may have broken id3 mode
Comment by Norbert Preining (norbusan) - Saturday, 27 January 2007, 23:17 GMT
Hi all!
Any chance to get an update for the new changes in the settings.c code?
Thanks a lot, Norbert
Comment by tim goff (goffa) - Sunday, 28 January 2007, 18:32 GMT
I removed the stuff pertaining to settings.c. Player compiled and patch works on my player. Your mileage may vary. Hope it works.
Comment by tim goff (goffa) - Monday, 05 February 2007, 04:33 GMT
updated for the ipod. I don't have an ipod, but was able to compile.
Comment by tim goff (goffa) - Tuesday, 06 February 2007, 15:51 GMT
found out what the settings.c does. Aparently, it saves changes to settings.c when you write a config. Unfortunately, i don't know how to update that code at the moment. If anyone could help, it would be greatly appreciated.

Still hoping this can be included in svn
Comment by Yohann Misquitta (fasmaie) - Thursday, 15 February 2007, 16:43 GMT
I have fixed this temporarily (for the gigabeat, at least), but will only post a patch when the code settles down (or it is likely to break quickly). If you want it, tell me at #gigabeat, and I'll give you the updated files.
Comment by Yohann Misquitta (fasmaie) - Friday, 16 February 2007, 02:39 GMT
Made a temporary patch. Changes in the RockBox code have made me change this twice in the last few days, so this may not work when new changes are made.

Hope it works for you.
Comment by Yohann Misquitta (fasmaie) - Friday, 16 February 2007, 03:04 GMT
Well, there was the dreaded slight change in code...broke the patch. Here's a revision.
Comment by Yohann Misquitta (fasmaie) - Sunday, 04 March 2007, 17:28 GMT
This fixes the patch for code changes until 20070304. The click-insert settings are now nested in Settings:General Settings:Playlist. I could put it in the root:Playlist menu, to make it more easily accessible, but it really is a playlist setting and should be in the General settings.

Comment by Gary Light (evilg123) - Saturday, 24 March 2007, 23:56 GMT
Fixed to cope with changes in playlist_menu.c needs some tidying up (offsets fuzz 1) but I don't know how to code so I'm surprised I even got it to work :)
Comment by Ryan Sawhill (ryran) - Monday, 02 April 2007, 19:40 GMT
I sooooo hope someone can help with this. More issues in playlist_menu... I couldn't fix it easily.
Comment by Yohann Misquitta (fasmaie) - Tuesday, 03 April 2007, 00:08 GMT
Don't know what the problem is that you're having, Ryan. The patch Gary put up should work. However, here's what I use, just in case.....
Comment by Ryan Sawhill (ryran) - Monday, 30 April 2007, 20:12 GMT
Can someone tell me what the stuff at the end [of the patch file] patching wpslist has to do with this patch?
Comment by Yohann Misquitta (fasmaie) - Tuesday, 01 May 2007, 02:12 GMT
Ryan - Actually, nothing! I have removed it in the one I use.
Comment by Yohann Misquitta (fasmaie) - Tuesday, 01 May 2007, 02:23 GMT
Here's a new one. There's some fuzz. I'll take care of that later.
Comment by Jonathan Gordon (jdgordon) - Saturday, 04 August 2007, 11:15 GMT
this patch doesnt work with the database. so If you want it commited that needs to be fixed.
Also, there is no chance of commit as long as 1) this isnt ifdefed to only work for targets which have a spare button (i.e not ondio), 2) is changed to replace ACTION_STD_OK when a target has 2 buttons which can do that (iriver, sansa, ipod, you wold use right instead of SELECT), 3) add an enum for the various setting values, if(global_settings.click_insert==1) is nasty. 4) the stuff in playlist_menu.c (the option config) needs to be moved to settings_list.c (copy the CHOICE_SETTING() macro items).
Comment by Andrea Minini Saldini (gorman) - Monday, 20 August 2007, 13:02 GMT
Any chance of having this work with the database?
Comment by Yohann Misquitta (fasmaie) - Sunday, 26 August 2007, 16:55 GMT
I'll look into getting it to work with the database. Should take only a few days.
Comment by Yohann Misquitta (fasmaie) - Monday, 03 September 2007, 16:40 GMT
Here's the insert patch to make it work with recent code changes. Please tell me if there are any problems.
Comment by Mdkart (Mdkart) - Sunday, 11 November 2007, 17:00 GMT
Hi, I've make the modifications for make it work with the database mode.
Comment by tim goff (goffa) - Friday, 16 May 2008, 01:36 GMT
seems broken again ... fails on settings_list.c when i try to patch the current build
Comment by Mdkart (Mdkart) - Saturday, 17 May 2008, 13:07 GMT
It should be ok now.
Comment by tim goff (goffa) - Saturday, 17 May 2008, 19:35 GMT
awesome... thanks
Comment by Ryan Sawhill (ryran) - Wednesday, 04 June 2008, 01:47 GMT
Trivial fix of include for onplay.c -- recent menu-reorganization broke it.
Comment by Shiloh Hawley (gree665) - Tuesday, 17 June 2008, 17:44 GMT
I think this patch is a great idea. I have 2 comments:
-This patch causes SELECT not to work in the menus (have to use NEXT to choose menu items). It would be better if it did not affect the menus, only the file browser, in my opinion. I looked at the code a little, but it is beyond me. By the way, I am using a Gigabeat F.
-It would be nice if there were a "replace current playlist" option as well (similar to pressing ENTER while a track is selected from the file browser).
Comment by Ryan Sawhill (ryran) - Sunday, 16 November 2008, 04:18 GMT
Synched after r18997's change to settings_list.c
Comment by Ryan Sawhill (ryran) - Sunday, 30 November 2008, 05:01 GMT
Synched again after new backlight stuff in settings.h...
Comment by Thomas Martitz (kugel.) - Tuesday, 23 December 2008, 00:39 GMT
Hm, can you add E200? That one has a free REC button (only holding REC is used to get to the recording screen).
Comment by tim goff (goffa) - Wednesday, 28 January 2009, 04:32 GMT
seems like something broke this patch again. Something in settings.h
Comment by Thomas Martitz (kugel.) - Thursday, 05 February 2009, 14:26 GMT
I don't think the patch has a change, seeing it's basically giving configurabe buttons, which is a NOGO.

I've put a similar patch up at  FS#9873  . consider contributing to it please.
Comment by tim goff (goffa) - Saturday, 28 February 2009, 16:06 GMT
My target doesn't have a record button, but your patch looks nice for those targets that do.

Here's what my settings.h.rej says:


***************
*** 429,435 ****
bool backlight_fade_in;
bool backlight_fade_out;
#endif
-
#ifdef HAVE_BACKLIGHT_BRIGHTNESS
int brightness;
#endif
--- 429,437 ----
bool backlight_fade_in;
bool backlight_fade_out;
#endif
+ int click_insert; /*setting for click behaviour in file tree:
+ 0:insert, 1:insert last,2:queue,
+ 3:queue last,4:insert shuffled*/
#ifdef HAVE_BACKLIGHT_BRIGHTNESS
int brightness;
#endif

Loading...