Rockbox

Tasklist

FS#2687 - Rewinding at end of song confuses playback

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 21 September 2005, 03:16 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Tuesday, 08 January 2008, 14:31 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To Brandon Low (lostlogic)
Nicolas Pennequin (nicolas_p)
Operating System All players
Severity High
Priority Normal
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Using the rewind feature when an mp3 only has a few
seconds remaining confuses the firmware as to which
song is actually playing resulting in it NOT playing at
the current rewind position, but rather playing the
next track in queue(at the rewind position). In
addition, the wps for the next track in queue is not
displayed, the previous track's wps that was rewound is
still displayed. Going into navigation mode will
correct the wps display issue.

I could reproduce the bug reliably with mp3's. Flacs
and oggs appear to fine.

-Robert DiNicolas
bob@bah.net
iriver h120 firmware
using cvs-05-09-12
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Tuesday, 08 January 2008, 14:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in r16025.
Comment by Tony Lenox (lenox) - Tuesday, 18 October 2005, 20:27 GMT

confirmed
Comment by Christi Scarborough (christi-s) - Sunday, 19 March 2006, 14:34 GMT
Please report if this is still a problem with the latest builds.
Comment by Tim Crist (ts-x) - Monday, 20 March 2006, 15:20 GMT
Still a problem with 03/20/06 build (H3xx, ogg vorbis). Rewinding or attempting to skip to the beginning of the same song during last few seconds results in unpredictable behavior. The wps track information will either freeze or become out of sync with the song that is actually playing (e.g. playing track #4, but wps information for track #5 will be shown).
Comment by Brandon Low (lostlogic) - Wednesday, 05 April 2006, 13:05 GMT
From  bug 2942  (which is technically a duplicate of this):

If you stop the track in the last 3 seconds (during
gapless transition to the next track) and the device
shuts down - when switching back on the resume function
gets stuck and you must skip to the next track manually.

brian.a.martin@gmail.com
Comment by Brandon Low (lostlogic) - Wednesday, 05 April 2006, 13:06 GMT
Both of these are because technically the _decoder_ has moved on to the next song by the time the stop or rewind event is received, so the playback code gets confused as to which track it should be playing / resuming / rewinding.
Comment by Brandon Low (lostlogic) - Tuesday, 18 April 2006, 17:01 GMT
It won't be elegant, but I'll 'invent' a way to handle this for 3.0. It'll be better post 3.0 when I put metadata on the buffer.
Comment by yipely yiperson (yipe) - Saturday, 21 October 2006, 20:59 GMT
on the iPod Video I can reproduce this same bug by rewinding long distances no matter how far into a track the player is. During the last few seconds of a track it will begin playing the next track, but if I start rewinding BEFORE that point it will play tracks that come BEFORE the correct track in the playlist (and sometimes SEVERAL tracks before).
Comment by greg (hweb21) - Sunday, 22 October 2006, 00:39 GMT
yup, both ogg and mp3 files do this.
Comment by Magnus Lindström (mlind) - Sunday, 03 December 2006, 21:48 GMT
Still there. H120. Mp3, Wav & Aiff. Very disturbing.
Comment by dalton r (idioticlamb3) - Saturday, 24 March 2007, 02:07 GMT
Comment by Linus Nielsen Feltzing (linusnielsen) - Saturday, 19 May 2007, 21:27 GMT
This is a test comment to try out the new Flyspray version.
Comment by Alex Bridges (Acb5649) - Monday, 02 July 2007, 20:46 GMT
Prehaps if you DIDN't rewind the song and reselect it or, better yet, listen to the whole album. Dose this matter as much as other commits?
Comment by Steve Bavin (pondlife) - Tuesday, 03 July 2007, 07:01 GMT
All bugs matter, especially those affecting the fundamental use of a DAP.
Comment by Alex Bridges (Acb5649) - Tuesday, 03 July 2007, 21:20 GMT
DAP's Play music. Rewinding at the END of a song Dosent make sense. Now makimg the radio work on the H10 would affect the fundamental use of the player.


Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 04 July 2007, 06:29 GMT
You are supposed to be able to rewind a song at any point. This is a genuine bug in the playback code and it should be fixed.
Comment by Raúl Núñez de Arenas Coronado (DervishD) - Wednesday, 01 August 2007, 22:19 GMT
A bit different: if I try to rewind when only a few seconds of the current FLAC file are left, the progress bar move backwards... and jumps to the point where it was, just as if I never tried to rewind. I mention FLAC because it is the format I was using when noticed the problem. Difficult to reproduce this, though :(
Comment by j (infamis) - Sunday, 12 August 2007, 04:22 GMT
Don't know if it's the same bug, but hitting 'previous track' towards the end also confuses playback. After hitting 'previous track', the _next_ track starts to play and the wps still shows the old track that was playing when you hit previous track. Hitting 'previous track' any number of times when this new track starts to play only restarts that track (instead of going to the previous track). Like mentioned above, going into file view & then 'now playing' fixes the problem...except if you didn't do that, you would have to hit next track (so that you are now @ track_you_wanted_to_start_from_the_beginning + 2) and then hit previous track twice.
Comment by Jan (dumbo20) - Wednesday, 07 November 2007, 16:51 GMT
I noticed the same bug (or if these are different, both bugs) on my sansa e250 with flac-files. r15510-071107
Comment by Richard Sweeney (riksweeney) - Tuesday, 27 November 2007, 08:15 GMT
I think I know what is causing this bug from a coding point of view. Towards the end of the track, Rockbox will play the transition chunk, which is the end of the track currently being played and the start of the next track. The next track however is now registered as the current track, which means that when you rewind during the transition you start rewinding through the next track even though the current track is still being played. Hope this makes sense...
Comment by Steve Bavin (pondlife) - Tuesday, 27 November 2007, 08:39 GMT
Yes, the problem is that there are actually 2 track transitions:
1) Internally to playback.c, when the codec moves from track A to track B.
2) Externally to playback.c, when the WPS moves from track A to track B.

The codec transition happens a few seconds before the WPS transition. If the user attempts a seek in this interval, horrible things happen!

All interfaces to playback.c need to refer only to the WPS transition, and corresponding track. I suspect the outputs are correct, but the inputs (seek position, in this case) are using the codec transition.

Loading...