FS#290 - screen went blank...

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 25 September 2002, 01:58 GMT
Last edited by Daniel Stenberg (bagder) - Wednesday, 09 March 2005, 10:35 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To Linus Nielsen Feltzing (linusnielsen)
Operating System
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I can't reproduce it but on one of the tunes about 2
minutes into the song battery and volume levels were all
that were showing. The timer and title disappeared no
matter what I hit. Happened once, and cant' reproduced.

I loaded the latest player build as of today
Keep up the good work....
This task depends upon

Closed by  Daniel Stenberg (bagder)
Wednesday, 09 March 2005, 10:35 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 27 September 2002, 09:42 GMT

Please inform us if you manage to reproduce it.
Comment by Vincent Kargatis (kargatis) - Friday, 27 September 2002, 09:54 GMT

This looks to me like a standard disk error hang - did the
music continue playing when this occurred?

I see this happen occasionally, though the music hangs.
Sometimes I can recover by hitting next, sometimes I must
reboot. I figured this was going to be treated by enhanced
disk error recovery, which I saw Bjorn mention?
Comment by Vincent Kargatis (kargatis) - Friday, 27 September 2002, 09:57 GMT

That is, I'd guess this is a dupe of 578026, though not
necessarily so...
Comment by Nick Lawes (nplawes) - Tuesday, 15 October 2002, 11:43 GMT

I loaded the firmware for the first time yesterday (great
stuff!!) and have seen this problem twice now.

The music keeps on playing. It steps onto the next track
etc, but the two text lines do not appear to come back their

The first time, I powered off and it was fine when I powered
back on and resumed.

I think the second time, I pushed the stop button and got
back to the top level directory (I had been one deep), but
the screen came back at that point.

I am currently playing a large playlist (700+ tracks,
shuffled) from a directory below top, and the files are in a
directory below the playlist...

playlist is \various\%misc.m3u
datafiles in \various\misc\album\tracks....

I can't reproduce the fault at will, but given that I've
seen the problem twice within 24 hours, and I'm still
playing the same playlist I guess it may happen again. If
there are any tests that I can do if it happens again,
please let me know... I will try noting the track and
finding the position within the playlist file etc...

Comment by Icabod Craine (icabod) - Tuesday, 10 December 2002, 19:58 GMT

I get the same problem. It seems not to be limited to large
playlists. I have encountered it when playing from a directory
(with ~10 files in it) and when playing a playlist (~45 - 700
files). It happens on CBR files and VBR files.

Usually, I will be listening while working, and look down to
see the WPS is blank (status bar still on). Hitting Next and/or
rebooting makes it stop.

Vital statistics:
AJBR15 v 1.28
Rockbox v 1.4
Comment by Anonymous Submitter - Monday, 12 May 2003, 18:21 GMT

no track display on playback...
(rockbox v2.0 / recorder 15gb)
Comment by scott m (scott666) - Wednesday, 25 June 2003, 21:50 GMT

i've seen this too. it seems to happen at random times. i have
an FMR20

Comment by Anonymous Submitter - Wednesday, 16 July 2003, 21:36 GMT

I found this problem also. Don't leave it in a hot car!, once it
had cooled down it seemed to work ok.
Comment by Stealth (stealth77) - Sunday, 09 November 2003, 17:10 GMT

I have the same problem tha it is mentioned in all post here.
Any solution?
Comment by Linus Nielsen Feltzing (linusnielsen) - Wednesday, 17 November 2004, 14:52 GMT

This is supposed to be fixed in CVS. I'll mark it as
"fixed", and if it turns up again, we'll reopen it.