FS#2945 - Playback stops suddenly on recorder v1

Attached to Project: Rockbox
Opened by Anonymous Submitter - Tuesday, 24 January 2006, 01:41 GMT
Last edited by Christi Scarborough (christi-s) - Sunday, 19 March 2006, 12:48 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Immediate
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Sometimes when listening to music the playback just
stops on my Recorder V1. When this happens, the screen
is back at the file browser. I hit the 'On' button and
Rockbox loads the playlist and begins playing right
where it left off.

-It seems to be pretty random, and occurs often (when I
last checked, it was 3 times in less than 2 hours)
-My batteries are over 50% full
-The unit is out in the open; nothing to accidentally
press a button

I never had a problem with this before. The build I'm
running is the special build Linus compiled to test and
update to the charging software, details here: I
believe that the special build is built on code from
the Jan 17 or 18 '06. Prior to flashing this
particular version of Rockbox, I had been running a
daily build released about 10 days or so after 2.5 was
released. It never gave me any problems like this.

This is what Linus had to say about the problem:
"Interesting. Maybe you have one of those recorders
that detect fake STOP button presses when the drive
spins up. The latest Rockbox builds might be more
sensitive to those events."

So perhap Rockbox is too sensitive to button presses now?
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Monday, 24 April 2006, 06:08 GMT
Reason for closing:  Fixed
Comment by Markus Braun (malle) - Thursday, 26 January 2006, 15:36 GMT

The same happens for me on my V1 recoder. A current cvs
build runs fine, as long as the batteries are almost full.
As soon as the go down to about 50-60% I get fake button OFF
presses on almost every disc spinup. Sometimes they are
short and just stop playback, somtimes the are long enough
to show "Press off to shut down" and somtimes the fake
button presses are long enough to really shut down the recorder.

If I rolo to rockbox 2.4 or 2.5 at this point everything is
fine and the recoder keeps playing during spinups until the
batteries are empty.
Comment by Daniel Stenberg (bagder) - Wednesday, 19 April 2006, 21:58 GMT
Is this still happening in a recent CVS build?
Comment by Jeff Nemic (zipr) - Monday, 24 April 2006, 02:33 GMT
I think that this is now fixed. I'm using a daily build from 060407, and have run my recorder down to 6% charge without any false stops at all. I think that my unit seemed to have more of these than others in the forum, so I'd say that it is now fixed.