FS#416 - Red led dead

Attached to Project: Rockbox
Opened by Anonymous Submitter - Monday, 14 October 2002, 01:47 GMT
Last edited by Daniel Stenberg (bagder) - Wednesday, 29 June 2005, 10:04 GMT
Task Type Bugs
Category Drivers
Status Closed
Assigned To Björn Stenberg (zagor)
Operating System
Severity High
Priority Urgent
Reported Version Daily build (which?)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Hardware: JB6000
[HW Info]
ROM: 5.02
USB: neg
ATA: 0x300
Mask: 0000

Has occurred at battery levels between 25% and 100%
with unit running on batteries.

I was listening to the JB in random play. About 3
minutes into a 4 minute song, the player stops playing.
I pulled it out of the case, and the timer had stopped,
and the red drive light was on solid. I presssed stop,
but nothing changed. I had to turn the unit off then
back on to restore.

The second case happened about 30 minutes later. I was
in the data center with the unit in my shirt pocket. I
leaned forward, then back again and the back of it
tapped my chest and I got the same indications as above
and had to do the same thing to fix it. A few songs
after resetting it, I pressed stop to change
directories. The JB froze in place, with the drive
light blinking on-off at about half-second intervals.
Again, I had to turn off to recover. This has happened
several times, both when the unit was stationary and in

I suspect that it could be the error recovery code that
is doing this. In
earlier versions (e.g. 1.3), a drive error would cause
the JB to skip to
the next track. Is it possible that now you get this
wierd issue if you get
an error.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Wednesday, 29 June 2005, 10:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  Logged In: YES

The RLD bug is believed to be fixed in current CVS.
Comment by Anonymous Submitter - Wednesday, 16 October 2002, 13:56 GMT

I have experienced a similar problem to this with the
recorder. It seems to mostly occur when driving on a
bumpy road (I use the recorder in my car). The problem
also seems to be worse when the battery is low. In my
case, the drive light eventually goes out, but the music
does not start again until I cycle power on the unit.
Archos Recorder 20 v1.28c. Rockbox v. 1.4
Comment by Anonymous Submitter - Wednesday, 16 October 2002, 13:57 GMT

I have experienced a similar problem to this with the
recorder. It seems to mostly occur when driving on a
bumpy road (I use the recorder in my car). The problem
also seems to be worse when the battery is low. In my
case, the drive light eventually goes out, but the music
does not start again until I cycle power on the unit.
Archos Recorder 20 v1.28c. Rockbox v. 1.4
Comment by Anonymous Submitter - Wednesday, 16 October 2002, 13:58 GMT

I have experienced a similar problem to this with the
recorder. It seems to mostly occur when driving on a
bumpy road (I use the recorder in my car). The problem
also seems to be worse when the battery is low. In my
case, the drive light eventually goes out, but the music
does not start again until I cycle power on the unit.
Archos Recorder 20 v1.28c. Rockbox v. 1.4
Comment by Björn Stenberg (zagor) - Friday, 01 November 2002, 16:34 GMT

The blinking light means it hit a software bug. The failing
address is displayed on-screen.

The solid light is a bug, but we find it very difficult to
reproduce. If you can come up with a sequence of events that
increase the chance of it happening, that would be great.
Comment by Anonymous Submitter - Wednesday, 27 November 2002, 14:28 GMT

I experience the same problem, it seems to happen more often
with low batteries and cold temperature. The HD light stays
on, the time keeps on counting, but I hear no music.
Sometimes I hear strange sounds, like the HD ist spinning up
and immediately shutting down again every few seconds. Also
the backlight brightness changes slightly. Archos JB6000
5.05 Rockbox 1.4
Comment by Anonymous Submitter - Thursday, 28 November 2002, 03:02 GMT

I will check next time I get a blinking light. I have never
had it occur when it is plugged into the charger (car or
house), but there is an issue of mobility. Most of the time
when it occurs, I have the Archos on my person, either in my
hand (in the case with my fingers through the belt loop or
in a shirt pocket. In one case, it happened about (call it
30) seconds after I placed it on a counter. In all cases,
any movement of the unit is minimal (e.g. its not like I'm
slamming it around or shaking it violently).

I took the liberty of defragmenting the drive on the Archos,
as well as replacing the batteries, but I have noticed on
more than one occasion that it has done it with a full
battery. I wish I could provide more information, but there
is no one thing that seems to cause it.
Comment by Björn Stenberg (zagor) - Tuesday, 28 January 2003, 12:31 GMT

Is this still happening to anyone?
Comment by Brad Alexander (storm16) - Tuesday, 28 January 2003, 19:14 GMT

It is still happening to me. It doesn't seem to happen as
often, but it does still happen. Lately, I have mainly been
using it in the car rather than carrying it around, but it
happens on occasion even sitting flat in the car.
Comment by Anonymous Submitter - Wednesday, 29 January 2003, 08:05 GMT

It might be a hardware problem, at least on my player. When
I touch a connector plugged in the earphone or line-out
port, the backlight flickers and sometimes the player just
shuts down. I have opened the jukebox, but found no loose
connections. The battery connectors seem to be ok (i
connected an external battery directly to the connectors and
the problem still occured.)
Could it be the HD connector? I didn´t dig deep enough, just
opened the case and checked what i could see....
Comment by Anonymous Submitter - Friday, 07 February 2003, 20:53 GMT


I have the same problem on a JB 6000 - Firmware 5.03.
IT IS DEEPLY FRUSTRATING! Some genious please fix
this :-)

Symptoms and observations:
Playing freezes part way through a track when it goes for the
HDD. Red light stays on and a power cycle is required.

Things I've noticed:
It happens more often when its cold.
It happens more often as the battery discharges.
It seems not to happen when the mains is plugged in.
It happens if there's even slight movement of the device.
I find that holding the JB still, display face down seems to
help it not happen (!!!!)
I've tried setting HDD spin down to >120 seconds to see if not
letting the HDD spin down would help; it didnt help much.
It almost never happens when you just press Play to start a

Sometimes, the JB fails to initialise correctly when loading
the RockBox firmware - I wonder is H/W intialisation is dodgy.

I also feel this is related to the internal voltages in the device;
I'm considering getting higher charge NIMH batteries to see if
that would fix it (do 1.4 NIMH exist?).

The best course of action would be to initially fix the HDD
read logic to re-try in the event of an error (even if the tune
stalls), or to skip to the next track like 1.3 RB firmware did.

Is there anyway of sending ATA commands into the HDD to
make it more reliable (power save mode, quiet mode, or
something) what to Fujitsu have on that drive anyway?

Thanks for your attention.
Comment by Brad Alexander (storm16) - Saturday, 08 February 2003, 02:42 GMT

I guess that I should have mentioned in my last post that I
am using archos20030131.mod...I have been using daily builds
since 20021208, and have been updating it about ever 5 or 6
Comment by Anonymous Submitter - Tuesday, 25 February 2003, 16:44 GMT

I get this problem (crash when HD spins up) on my FM
recorder, using both Rockbox and the Archos firmware. It's
fine when the battery is full, but the machine locks more and
more often as the battery runs down - I end up recharging
when it's crashing too often, rather than when the battery is
truly flat.

It looks to me as though the power surge drawn by the HD as
it spins up is either crashing either the main processor or
putting the HD in a funny state from which it needs a reset.
Music continues playing until the buffer is empty, though.
Comment by Mike Holden (mikeholden) - Tuesday, 25 February 2003, 17:16 GMT

Yes, I get this as well, and have been unable to find a fix as yet. This is
on an FM model, with up-to-date daily builds.
Comment by Anonymous Submitter - Friday, 28 February 2003, 14:32 GMT

Sadly the fix in archos20030228.ajz doesn't work - I'm
listening to my FM recorder right now and it's just crashed.
It's been playing for a couple of hours already with no
problems, but the battery is just starting to get a bit low and it
hung with the red light on as usual.

Comment by Anonymous Submitter - Sunday, 23 March 2003, 20:07 GMT

I get the same problem with my archos studio 20 I am
using rockbox 1.4 firmware (which is great keep up the
good work) daily build rockbox-daily-20030321.tar.gz.
hope u guys can help cheers
Comment by Bernd Schymanski (alaimo) - Monday, 14 April 2003, 09:31 GMT

I have the same problem with my archos Jukebox Recorder
20 running the daily build archos20030414.ajz, the box locks
while opening a playlist (.mru)
It does even happen when the box is connected to mains
It didn't happen with the latest version 1.4
Comment by Anonymous Submitter - Sunday, 27 April 2003, 08:21 GMT

Same problem for me with the FM recorder. This bug makes
rockbock unusable for me as the unit locks up every couple
of songs. Having to revert back to installed software.

Comment by Björn Stenberg (zagor) - Tuesday, 29 April 2003, 12:16 GMT

Everyone having this problem, please read this and help us find the bug:
Comment by Mike Holden (mikeholden) - Tuesday, 29 April 2003, 12:57 GMT

For the time period mentioned in that email, the FM was not stable
enough to use. It was late January 2003 at the earliest, maybe February
before we got the fundamental issues on FM sorted. The firmwares in
the email are for recorder only, not FM.
Comment by Anonymous Submitter - Wednesday, 14 May 2003, 22:23 GMT

This happens to me too.

Recorder 20 on V2.0 and later daily builds.

Play stops with red led on solid - only thing to do it to switch

Can happen 2 or 3 times in a few minutes, then play for hours
without a problem.

I'll try the 4 'brute force' builds you posted......
Comment by Anonymous Submitter - Tuesday, 24 June 2003, 21:05 GMT

am gettin the same problems with my studio 20 am using
Rockbox version 2 ... daliy build archos20030623.mod.
Comment by Jason (rza_dmx) - Tuesday, 24 June 2003, 21:17 GMT

sorry i forgot 2 log in, am gettin the same problems with my
studio 20 am using Rockbox version 2 ... daliy build
Comment by christopher saunders (cis4z) - Thursday, 26 June 2003, 20:30 GMT

I get Red Led Dead at least once a day, since I using my
Archos Studio 10 while walking to work.

(I also get a similar problem wherein a song's sound stops
after a brief moment of disk activity -- but the song's timer
continues ticking.)

I'll be happy to test anything you guys whip up -- I'm eager
to help you get to the bottom of this.
Comment by Anonymous Submitter - Friday, 25 July 2003, 01:44 GMT

similar incident on jb recorder 6 gig. had in my pocket when
running to get the bus. suddenly the music stopped, so i got
out of the case and the archos firmware 1.27d said
something like 'harddisk failure'. after a restart the problem
was gone. had no other problems like that. sounds to me in
most cases that the HDD doesn't like to be shaken around.


btw. great work folks
Comment by Anonymous Submitter - Friday, 25 July 2003, 02:29 GMT

This happens to me to. I have studio 20. I'm sorry to say
this, but this never happened before I used rockbox. I really
like all the added features. It happens to me in every
situation. It happens the most when I am walking with it.
Comment by Dave Curr (demonmaster) - Wednesday, 06 August 2003, 15:41 GMT

I get the continual REDLED hang regularly, but it is totally
unpredictable. I use it for 1hr 40mins twice a day, sometimes
it's fine, sometimes it happens twice in a song. I don't change
the files on the disk much (it's a recorder 20 and pretty full)
and it's doesn't affect specific songs. it's bit rate independent
(i use 128, 160, 192 and vbr, all are affected), it's
temperature independent (-10 to +35 C), it's motion
independent, battery level independent but i can't comment
on whether it works when charging as i don't use it whilst it's
charging. once or twice it's recovered after 90 seconds or so,
but normally it needs a power off. I recently moved all the
files off and reformatted it, and it has made no difference. i'll
be more than happy to help test any daily builds. I've used
20030802, 20030803 and 20030804, all of which suffer the
problem. HDD diags show the unit functioning correctly (it's a
Hitachi) and a surface scan shows no issues. I've also
noticed it seems to happen a lot if you seek back and forth
inside a track. 1.4 didn't have this problem. the timer always
continues to count when this happens (sorry this is
disjointed - i'm reading through the other postings and
commecnting where relevant).
Comment by Björn Stenberg (zagor) - Wednesday, 06 August 2003, 17:21 GMT

This is a long-shot, but it hasn't been mapped yet. Can
those of you who get this regularly please post your "ATA:
" line from the debug->hw_info menu entry (using latest
daily build), plus the make and model of your harddisk
(available from debug->disk_info).
Comment by Dave Curr (demonmaster) - Thursday, 07 August 2003, 08:07 GMT

ATA: 0x200 master
Hitachi DK23DA-20
Comment by Brad Alexander (storm16) - Thursday, 07 August 2003, 21:12 GMT

Mine says

ATA: 0x300m
Model Fujitsu MHK2060AT
Comment by Dave Curr (demonmaster) - Friday, 08 August 2003, 16:22 GMT

if it helps the debug menu is accessible in the 'hung' state.
Comment by Dave Curr (demonmaster) - Monday, 11 August 2003, 07:26 GMT

if it helps the debug menu is accessible in the 'hung' state.
Comment by Jason (rza_dmx) - Monday, 11 August 2003, 19:32 GMT

model IC25N02ATC004-0
ATA: 0x300m

sorry it took so long 2 reply. i did notice that cvs-030630 did
seem to make the red light not happen as often. cheers
Comment by Jason (rza_dmx) - Monday, 01 September 2003, 19:09 GMT

do you where i can get cvs-030630 daliy build from. as the
daliy build since hasnt improved the red led dead problem in
fact its made it worser. am currently using cvs-030830

model IC25N02ATC004-0
ATA: 0x300m
Comment by Anonymous Submitter - Tuesday, 09 September 2003, 15:05 GMT

I have the problem with the 2.0 release of Rockbox:
ATA: 0x300m
Disk Info: Fujitsu MHN2200AT
Comment by christopher saunders (cis4z) - Tuesday, 09 September 2003, 16:42 GMT

Still have the problem. In fact, seems more frequent, if
anything. Using Jukebox Studio 10, daily build CVS-030905.

ROM 5.06
ATA 0x300m
Comment by Dave Curr (demonmaster) - Wednesday, 10 September 2003, 19:10 GMT

i managed to tear the belt loop off the neoprene carry case,
so i bought a new case for it which holds the unit on it's right
hand edge. Since then (4 weeks ago) i've not had a single
Comment by Brad Alexander (storm16) - Monday, 15 September 2003, 13:49 GMT

I believe this may be two separate problems. I have also
noticed that disturbing the battery bumpers on the Jukebox
causes the red dead led, but simple movement can also cause it.
Comment by Kevin Lai (kevinlai) - Saturday, 11 October 2003, 11:55 GMT

i having same problem that the red led blink when the
harddrive spin and when sometimes it try read the music.
using Archos Studio 10
rom: 5.06
usb: neg
ata: 0x300
mask: 0000
Disk info: IC25N010ATDA04-0
Comment by Anonymous Submitter - Thursday, 16 October 2003, 05:18 GMT

I've had this problem on my recorder 10 from v2.0 to the
recent builds. I can't remember this ever having been an
issue when the batteries are well charged: 50-100%, and I
don't move the unit (ie when listening to music at school).
Later in the day, when the batteries are almost drained and
I'm walking around with it in my pocket it sometimes gives me
hell. When it happens it usually locks up about every 20
minutes (red light solid, nothing but the wps screen with the
timer stopped)
hitachi dk23da-10
Comment by Peter Hunt (cannon_fodder) - Sunday, 23 November 2003, 13:54 GMT

I recently upgraded my JBR20 (vanilla rockbox 2.0) using the
Fujitsu MHT2040AT (Firmware 009B). With the stock hard
drive I never observed the problem and since the upgrade I
have noticed it frequently. I have not been able to find a
corelating factor as yet
size/tempertaure etc etc) that affects the frequency of RLD.

I have been watching my MPEG thread window closely... RLD
always seems to occur on a disk read (i.e. when the MPEG
buffer is being filled). When RLD occurs the disk simply seems
to fail to respond to the 'read' request.

Interestingly, I have also observed that if I wait for exactly 1
minute 20 seconds then the box recovers. The 'read'
completes, the buffer refills, and the song resumes from the
stopped point.

I know this is reaching but I suspect that the ATA bus is
entering some sort of error state as a result of the 'read'
command and that after 1 minute 20 seconds something
times out, probably resetting the bus and allowing the 'read'
to complete.

As this behaviour has not been observed by any user I
further hypothesise that it must be the Fujitsu drive that
issues the reset.

All this is pure conjecture obviously. However I would be
interested to find out if there is anything significant in
(possibly in the ATA spec?) the 1 miniute 20 second wait.

Also, I used to work for a company that had a real-time ATA
analyser. This tool allows the user to monitor ATA activity on
the bus and observe (at the hardware level) bus activity and
error condidtions and how they are handled. I suspect that if
someone could obtain one of these ATA monitor tools then it
might well shed light on the problem (anybody got one??)

Finally, (perhaps this should be in hardware mods) I have also
experienced the problem where squeezing the rubber corner
pieces could cause the unit to reset. I discovered that there
is a solder joint between the PCB with the battery connectors
on it and the case/main pcb. Over time (and as a result of
changing the batteris a few times) this joint had begun to
fatigue. I resoldered this connettion (pushing the Batterry
connertor hard up against the battery again) and since then
the connetion to the battery has been solid as a rock.

Let me know if you want more detail on this 'mod'.


Comment by Mike Holden (mikeholden) - Sunday, 23 November 2003, 15:16 GMT

That analysis certainly backs up my findings posted on the
mailing list in the past. The drive fails to wake up from
its "slumber" state (it goes in to this state when the disk
spins down). It continues to show a status of 80, which
means it is "busy". Sometimes it wakes up again after being
given further reset commands. Sometimes it needs a power off
and on to clear the state. One minute 20 seconds also backs
up my findings, as the wait period is 10 seconds, and the
wait period is run up to 8 times, so 80 seconds = 1:20.

I petitioned for shortening this wait time, but was told
that this would break the ATA spec so we couldn't do it. I
have successfully run my own patched version with a timeout
of less than a second (instead of 10 seconds), and this
reduces the effect of RLD significantly. However it doesn't
stop it happening.

Analysing the ATA signals could enable us to find out what
the original Archos firmware does to spin down the disk so
we could implement this ourselves.
Comment by Peter Hunt (cannon_fodder) - Tuesday, 25 November 2003, 00:48 GMT

Following on from my previous post...

I have discovered the switching the SYSTEM> DISK
POWEROFF option to 'YES' seems to have eliminated my RLD
problem. I have now had the unit running for about 8 hours
without a single RLD event whereas previously they were
occuring around every 30 mins or so.

Still early days but this seems to work for me.

This would seem to support the last post which suggested
that 'The drive fails to wake up from
its "slumber" state'.

I does seem to wake up properly from off state.
Comment by Mike Holden (mikeholden) - Tuesday, 25 November 2003, 09:13 GMT

For anyone reading this, I would just point out that the
poweroff option is not available on the FMR models. There is a
good reason for this!
Comment by Björn Stenberg (zagor) - Tuesday, 25 November 2003, 09:16 GMT

Thank you for your excellent reports.

I'm just adding this note here to say that with my new 80gig
Fujitsu MHT2080AT, I have for the first time experienced this
bug myself.

It happens only very rarely for me though (only once last
week, and twice so far this week) but at least it gives me the
possibility to debug the problem.
Comment by Brad Alexander (storm16) - Wednesday, 26 November 2003, 05:29 GMT

I have, thus far, not foud a SYSTEM > DISK POWEROFF option
on the JB6000. Perhaps I am looking in the wrong place, but
the closest I found was GENERAL SETTINGS > SYSTEM > DISK
SPINDOWN, which I left at 5s (the default) and GENERAL
SETTINGS > SYSTEM > IDLE POWERDOWN, which was set to no,
but I upped to 10 minutes. Neither of these seem to fit the

Also, I noticed just the other day, that the RLD error
occurred during play. I happened to be in a place that I
could see the unit, and the song, which was 2:38, faded and
came to an end. Instead of hitting the 2:38 mark and
proceeding to the next song, it proceeded to count up
further, to about 2:42 before I had to reset it. I was in
the car, but as I recall, the red LED cam on _after_ it
passed the end of the song.
Comment by Anonymous Submitter - Tuesday, 03 February 2004, 20:29 GMT

Possible factors may be; cold, low battery (note that NiMh
batteries that are cold appear to be low on power!),
certainly movement, and happens during spin-up. Perhaps
there is not enough current and/or voltage?
Comment by Anonymous Submitter - Thursday, 04 March 2004, 03:23 GMT

some more information, I had been having the red light of death issue
for some time, mostly when running / walking w/ the jukebox. I had
tried many suggestions via the mailing list and this report.

So I went and dowloaded the original firmware from archos. Tonight
while running, I used rolo to use the archos firmware, and it did not die
once, which it would normally do several times during a 20 minute jog.
Another thing i noticed is when loading a playlist it first reads the entire
playlist, and notes how many songs there are. Could this be the key to
the redlight issue?

in the mean time i will just have to switch to the archos firmware to run,
which is no fun, because in general it sucks compared to rockbox.
Comment by Anonymous Submitter - Sunday, 18 April 2004, 07:48 GMT

I have a comment to make on this issue as well. I use my
studio 20 in my truck with a power adapter and have the
same problem, so I can say it isn't just a low battery issue.
My studio 20 will run about 20-40 minutes before it just quits
playing a song. I have noticed it doesn't matter if the truck is
moving or I am sitting in the parking lot at work (while at
break) listening to it. I also noticed that sometimes the time
remaining counter keeps moving, sometimes it also stops.
when it happens sometimes the unit recovers sometimes it
doesn't. Like others have said I didn't have this problem with
the Archos firmware eather, although I really like the rockbox
firmware much better since the features are pretty cool and
useful. I really hope you can fix this problem I really don't
want to switch back to the archos firmware. Anyhow I hope
this sheds some more light on the issue.
Comment by Anonymous Submitter - Thursday, 24 June 2004, 06:21 GMT

I just started haveing this happen with my Recorder 20GB. It
was happening with the Archos firmware so I tried the Rocbox
to see if it helped. It didn't.

I reformatted the HD (Windows 2000) using a FULL HD
FORMAT, (don't use quick format) and afterwards so far it
seems to be working. 8 hours without a problem so far. I will
test on my walk tonight to make sure.

FYI: The first time it happened, I tried defraging the HD to fix
it. The more I defraged, the worse the problem became.
Specifically, the symptoms were this. It happened once on my
45 minute walk. I defragged. It happened twice the next
night. I defragged again, It happened 2-3 times per night for
the next 5 nights. Finally I defragged numerous times till the
disk was completely defragged. When I walked after this, it
would not run longer than 5 minutes without freezing up.
After the Full Format above, I have not had a single freeze up
in 8 hours of playing.

Remember, this was with the Archos 1.4 Firmware that came
on it, so I don't think the problem is fixable in RoxBox.
E-mail is calthomas at to reach me.
Comment by Daniel Stenberg (bagder) - Wednesday, 29 June 2005, 10:04 GMT

The RLD bug is believed to be fixed in current CVS.