FS#445 - custom font lost when resuming playlists

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 16 October 2002, 16:58 GMT
Last edited by Björn Stenberg (zagor) - Tuesday, 15 April 2003, 22:39 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To Linus Nielsen Feltzing (linusnielsen)
Operating System
Severity Low
Priority Normal
Reported Version Release 1.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


First of all, here's my info:
Jukebox Recorder 20 (upgraded to 30g IBM drive)
Rockbox v1.4
ROM 1.28
Mask: 0x0302
USB: positive
ATA: 0x200
PR: positive
Freq: 11.0592MHz

I'm using the atadore font and all is well, usually. When I
power up the machine and if I choose to resume, the
WPS is not displayed in the atadore font. Hitting F1 or
the ON button to get to another screen clears things up.
It only happens when I'm resuming a playlist, so I'm
guessing it has something to do with the "Loading..."
screen, if that's helpful at all.

Eric Trondson-Clinger
This task depends upon

Closed by  Björn Stenberg (zagor)
Tuesday, 15 April 2003, 22:39 GMT
Reason for closing:  Fixed
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 28 October 2002, 23:13 GMT

I can't reproduce this. Can you give me some more info?
Comment by Anonymous Submitter - Wednesday, 30 October 2002, 21:46 GMT

I'm not sure what kind of information you might be looking for,
but I'll do my best to shed some more light on it.

I have Resume set to Ask. I have the atadore.fnt file located
in the .rockbox directory. The playlists are at the root and
contain the full path to the MP3 (G:\A-C\Artist\Album\01 -
Track Title - Artist.mp3). If I power down the Archos while
listening to a playlist, the next time I power up the Archos, it
asks if I want to Resume. If I select Yes, it reloads the
playlist, resumes where it left off and goes to the WPS
screen. The WPS isn't displayed in the atadore font though. I
can't tell which font it's using, but I'm guessing it's the default
font. If I exit the WPS screen by going to any other screen
(by pressing F1, F2, F3 or ON) and then exit and go back to
the WPS screen, it then displays correctly in the atadore

Let me know if there are any files that might be helpful to look

One possibility: I downloaded the atadore.fnt file from the
fonts page of the Rockbox website a while ago and am not
using the version that was part of the 1.4 release. Has the
atadore.fnt file changed at all recently?

Also, I was using 1.4 when I filed the bug report and have
since upgraded to the 10-21-02 daily build. It happens with
both versions.

Let me know if there's any other information that might shed
light on the situation. Thanks for all your work!

Eric Trondson-Clinger
Comment by Anonymous Submitter - Thursday, 31 October 2002, 21:45 GMT

Following a tip on, I reinstalled
the .rockbox directory and firmware from the 1.4 release and
it seems to have taken care of the problem. Let me know if
there's any other information that will help.

Eric Trondson-Clinger
Comment by Anonymous Submitter - Sunday, 19 January 2003, 17:07 GMT

This is still a problem when the Status Bar is turned off.
Custom font is not restored when playback is resumed when
the Status Bar is off.
Comment by Anonymous Submitter - Thursday, 06 February 2003, 15:31 GMT

I have this same problem (custom font not restored when
playback is resumed when the status bar is off). I am using
daily build from 20030129.

I have a 5-line wps display and turning on the recorder (with
resume set to yes) doesn't restore the custom font. If I turn
on the status bar and then power off and back on, it works
fine. Must be something with how the status bar font is set
versus the wps during startup.