Rockbox

Tasklist

FS#4801 - Can we get generic integration to iPOD accessories?

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 08 March 2006, 07:31 GMT
Last edited by Marc Guay (Marc_Guay) - Tuesday, 02 December 2008, 00:39 GMT
Task Type Feature Requests
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I think most of us can agree that Apple iPOD has a huge market for accessories and suckering many of us to buy accessories for our iPOD. I'm not sure how the technical details of the iPOD interface works or how much work this would take, but it would be great if some rockBox programmer creates a plugin/driver to support this. I myself use an iHOME system and would love to see it work on rockBox instead of the apple crapware. You guys rock!

Keep up the good work :)

This task depends upon

Closed by  Björn Stenberg (zagor)
Tuesday, 02 December 2008, 00:39 GMT
Reason for closing:  Invalid
Additional comments about closing:  Closing all feature requests.
Comment by Nils Wallménius (nls) - Friday, 10 November 2006, 18:51 GMT
I've closed tons of tasks requesting (i think) every single ipod
accessory out there referring to this one 'cause it covers the lot ;-)
anyway if anyone wants to use the itrip thingy there's a hardware hack
to make it work with rockbox here
http://pijulius.blogspot.com/2006/05/rockbox-itrip-and-ipod.html
Comment by junkers (junkers) - Monday, 08 January 2007, 15:56 GMT
I had made the following comment when I request support for Apple's HiFi external speaker system:

It would be wonderful if support could be added for the iPod HiFi external speakers. The sound works fine, but the excellent iPod remote has been rendered useful because of the lack of this support.
It is quite a pain to keep reaching out to shuffle the song, especially from bed!

Nevertheless, I swear by RockBox on the iPod, as I find it just impossible to navigate iPod's default operating system. File Directory view is just best for old timer like me!

----

However, it was deleted because it was considered a duplicate of this request. Looking here, I really have to disagree with that decision. Calling my request a duplication of this request thread amounts to an extreme abstraction of the two threads - in effect applying the logic that since the iTrip and the iPod HiFi are both accessories, they both belong together. If it is that a solution for one is also a solution for the other, OK. In this case I see no connection between the solution for the iTrip and what I am asking for. Somebody please point out what I'm missing here!!!
Comment by Nils Wallménius (nls) - Monday, 08 January 2007, 17:28 GMT
The point of feature requests is to inspire developers and to some extent tell them what the users want, every single one of the ipod devs know that the accerssories don't work with rockbox, making a new feature request for each and every one of them will not make them supported faster it just fills the tracker with lots of tasks.

And to answer why your request was closed as a duplicate, this request asks for _gneric_ support for ipod accessories which IMO covers all of them. I have, as I stated in my previous post here, closed lots of requests for individual accessories. Now everyone that reads this task will know that you want support for your accessory too. This is not the place for further discussion, if you feel you want to discuss it further please do it on the forum/ml/irc.
Comment by junkers (junkers) - Tuesday, 09 January 2007, 05:57 GMT
Thanks for the response Nils. Appreciate the quick responses.

Loading...