Rockbox

Tasklist

FS#4860 - Can't navigate menus using the H300 remote joystik.

Attached to Project: Rockbox
Opened by Fredrik Öhrn (ohrn) - Monday, 20 March 2006, 10:51 GMT
Last edited by Dave Chapman (linuxstb) - Thursday, 25 May 2006, 20:07 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Medium
Priority Immediate
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In the file browser or settings menu pushing moving the joystick right-left moves the selection up-down. Moving the joystick up-down has no effect.
This happens because the button mappings were selected with the H100 remote in mind.
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Sunday, 27 August 2006, 10:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  should be fixed with the button rework. If not please open a new bug.
Comment by Matthias Mohr (aka Massa) (mmohr) - Thursday, 27 April 2006, 16:26 GMT
Is this still the case in newer CVS?
Comment by Fredrik Öhrn (ohrn) - Friday, 26 May 2006, 21:37 GMT
Here's a patch that detects the type of remote at runtime and adjusts the relevant buttons accordingly. It's kinda ugly becasue the existing code assumes that all buttons are statically defined at compile time and I didn't want to redo everything.
Comment by Fredrik Öhrn (ohrn) - Friday, 26 May 2006, 22:42 GMT
Ooops, I forgot to map the joystick push button. Here's a new patch.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 29 May 2006, 13:05 GMT
How does this work with the H300 non-LCD remote?
Comment by Fredrik Öhrn (ohrn) - Monday, 29 May 2006, 13:23 GMT
It doesn't but then again it probably doesn't work that well right now either... :*)

I don't have such a remote but if someone can suggest how to best map it's buttons I can add it to the patch.
Comment by Linus Nielsen Feltzing (linusnielsen) - Monday, 29 May 2006, 13:38 GMT
I'll check it out.
Comment by Ioannis Koutoulakis (Genre9mp3) - Sunday, 18 June 2006, 02:42 GMT
OK...here are the problems with the H300 LCD Remote in detail:

- File Browser

1) ">" scrolls down the list, when ">" on the main unit goes into a folder or launches a file, and "V" normally scrolls down a list

2) "<" scrolls up the list, when "<" on the main unit goes up a directory level and "^" normally scrolls up a list

3) "^" and "V" do nothing, when "^" and "V" on the main unit scroll up/down a list

4) Joystick button goes into a folder or launches a file (as it should) but when you hold it, it doesn't go to the File Context Menu, while holding NAVI in the main unit goes to the File Context Menu

5) Stop shuts down the player if hold (as it should) but when just pressed it goes up a directory level, when Stop on the main unit stops playback and "<" normally goes up a directory level

6) Play goes back to the WPS (as it should) but when hold it goes to the File Context Menu, when holding Play on the main unit do nothing and holding NAVI normally goes to the File Context Menu

- Main Menu & File Context Menu

1) ">" scrolls down the menu, when ">" on the main unit goes into a submenu, and "V" normally scrolls down the menu

2) "<" scrolls up the menu, when "<" on the main unit goes back to previous menu or exiting the Main Menu and "^" normally scrolls up the menu

3) "^" and "V" do nothing, when "^" and "V" on the main unit scroll up/down the menu

4) Play goes into a submenu, when Play on the main unit do nothing, and normally only ">" and NAVI go to a submenu

- WPS & Quick Menu

Everything Seems OK

- Starting the player

Currently the joystick button starts the player. Since the joystick button coresponds to NAVI on the main unit, it shouldn't start the player but Play should. BUT in my opinion we should leave it that way, it's better.
Comment by Sylvan Mably (smably) - Wednesday, 21 June 2006, 07:08 GMT
I've updated this patch to fix the issues listed by Genre9mp3 above. I've also fixed a number of bugs from the last version by ohrn.

This version was tested with my H100 and H300 LCD remotes, so it should work correctly for them. I don't have access to an H300 non-LCD remote, so I don't know whether it works (I doubt it).

Please let me know whether this version's button mapping is satisfactory!
Comment by Ioannis Koutoulakis (Genre9mp3) - Wednesday, 21 June 2006, 13:32 GMT
smably: Great work!!! I tested your patch and it works like a charm! I couldn't reproduce any of the problems I had before with my H300 LCD remote. I don't have an H100 LCD remote to test though.

Now, about the non-LCD remote, everything works fine in WPS (all buttons do what they are supposed to do), pressing Play in File browser launches a file (as it should), ffwd and rewind do nothing in File Browser (BUT I think that they are supposed to do nothing so I don't see a problem here either). They only problem I found (tested with your patch but probably this is in the CVS as well) is that when you try to start the player with the non-LCD remote (by pressing Play) you get the "Hold switch on, Power off" message no matter if you have hold or not in the remote, so you are not able to start the player.

Since you don't have a non-LCD remote, I don't know if it's possible to fix that, but i imagine that this is something that could be easily fixed. I think we are close to full remote support (haven't tested the H100 LCD remote only). Someone with CVS access should check this patch.

Again smably, great work, thanks
Comment by Ioannis Koutoulakis (Genre9mp3) - Wednesday, 21 June 2006, 15:06 GMT
Just want to add that the problem with starting the player with the non-LCD remote is a bootloader issue after all, and it's no wise to mess with that. Though, navigation in Browser/Menu with left/right using the non-LCD remote, works in CVS and this should get fixed with the patch, too
Comment by Sylvan Mably (smably) - Thursday, 22 June 2006, 03:24 GMT
Attached is version 4.0 of the remote patch. Not a whole lot has changed in terms of functionality, but I've cleaned up the code a lot since 3.0. It's still a bit ugly, but much less so than before.

I've included limited support for the H300 non-LCD remote (REW/FF now scroll in the menu and filetree), but with this version's code changes it's very easy to change the button mapping. Perhaps owners of the non-LCD remote could get together and decide how they'd like the buttons to behave in each context. Something like Genre9mp3's description above would be particularly useful since I don't have a remote to test on.

Again, please let me know how this patch works.
Comment by Norbert Preining (norbusan) - Thursday, 22 June 2006, 11:22 GMT
included in my build of h300 experimental, works nice on a non-lcd-remote. Thanks a lot!
Comment by David Lee (iPood) - Thursday, 22 June 2006, 19:28 GMT
Relating to the non-LCD remote:

A long press on play currently does nothing. Would it be possible to get it to switch off the player?

Also whilst in the browser, the volume buttons currently do nothing. Would it be possible to use these to go up and down in the browser and the ff/rw buttons to enter/go back?

Thanks
Comment by Sylvan Mably (smably) - Friday, 23 June 2006, 06:11 GMT
New version. Remote buttons should work when browsing the playlist; I've also added very experimental support for shutting down when PLAY is held on the non-LCD remote. Please let me know whether non-LCD remote shutdown works. There's a new version in the works with a few more features, which I'll hopefully finish in the next couple of days.

In the meantime, bug reports/feature requests are very much welcome. :)
Comment by David Lee (iPood) - Saturday, 24 June 2006, 02:00 GMT
Shutting down when PLAY is held on the non-LCD remote doesn't work for me. Also with the lastest version only the PLAY button functions in the browser, the other buttons do nothing. Would it be possible to implement the other features in my last post? Thanks.
Comment by Martin Scarratt (mmmm-) - Friday, 28 July 2006, 12:12 GMT
A new way of doing things. Until the big button rework gets through...

Loading...