Rockbox

Tasklist

FS#4883 - USB charging mode does not work when in WPS

Attached to Project: Rockbox
Opened by Matthias Mohr (aka Massa) (mmohr) - Wednesday, 22 March 2006, 10:26 GMT
Last edited by Matthias Mohr (aka Massa) (mmohr) - Wednesday, 29 March 2006, 08:08 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Low
Priority Immediate
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I just compiled and transferred a new CVS build to my H340 device.
I listened to some music and while it plays I needed to charge it via USB.
So I pressed and hold the REC button and plugged in my USB cable.

Everything seems to be OK until I released the REC button
(I waited a few seconds before releasing)
After releasing the button it took about one second and then it jumps
to the USB connection (!) mode.
I must say: to a weird USB connection mode, because it still displays the
WPS backdrop in the background of the USB connection symbol.

Is this normal behaviour and I didn't notice it until now or is this a bug?
This task depends upon

Closed by  Peter D'Hoye (petur)
Wednesday, 26 April 2006, 20:49 GMT
Reason for closing:  Out of Date
Additional comments about closing:  seems to have been fixed for h300. Please add a new bugreport if this is not ok for ipod
Comment by Christi Scarborough (christi-s) - Wednesday, 22 March 2006, 12:59 GMT
Looks like a bug to me.
Comment by Jonathan Gordon (jdgordon) - Tuesday, 28 March 2006, 08:57 GMT
is this stil a bug? i just tested and it works fine..
Comment by Max Ried (bot47) - Tuesday, 28 March 2006, 18:10 GMT
Same with ipods.
Comment by Matthias Mohr (aka Massa) (mmohr) - Wednesday, 29 March 2006, 08:07 GMT
It seems to be somehow fixed lately - although I did not notice anything regarding it in CVS...

At least the USB charging mode now works here.

But the other problem with the weird USB connection mode still exists.
(it seems it does not switch back to the main backdrop - it keeps the WPS backdrop)

Actually this is the same as in the related bug #FS 4752:
http://www.rockbox.org/tracker/task/4752

So I think, this one here can be closed!
Comment by Max Ried (bot47) - Wednesday, 29 March 2006, 12:20 GMT
I don't think so, because it is broken on iPods, too, but since the ipod version of rockbox uses the ipod hardware disk mode, this is a different problem. The ipod just won't reset while in WPS.
Comment by Peter D'Hoye (petur) - Wednesday, 26 April 2006, 20:23 GMT
this seems to have been fixed (except for ipods? can't test that)

Loading...