FS#4889 - shutdown bug

Attached to Project: Rockbox
Opened by dave (user) - Wednesday, 22 March 2006, 14:16 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


when i try to turn off the device and hold the stop button, unless i hold it until the device gets out of the wps (which can take a few secs if the hdd was idle), it does not turn off; i have to again hold the stop button. i don't know how exactly it works but wouldn't it be possible to make the device turn off after one long-hold of the stop button?
This task depends upon

Closed by  Paul Louden (darkkone)
Sunday, 30 April 2006, 12:05 GMT
Reason for closing:  Fixed
Additional comments about closing:  Issuer says it\'s fixed, I found it to be fixed or not happening when I checked for it.
Comment by Paul Louden (darkkone) - Friday, 24 March 2006, 05:48 GMT
It turns off on one long hold for me, on h120
Comment by dave (user) - Friday, 24 March 2006, 13:18 GMT
only when viewing files, for me
it first gets out of the wps, whether long-hold or not. then if i'm still holding the stop button it shuts down, instead of catching the long-hold in wps and executing shutdown whether the hold is still there or not after getting out of the wps.
Comment by Matthias Mohr (aka Massa) (mmohr) - Sunday, 30 April 2006, 08:29 GMT
I'm not totally sure if I understand you correct,
but I don't see any misbehaviour in your description.

I personally never noticed this - so it doesn't seem
to be a problem for me :D

So I assume it's a feature, not a bug ;)
And changing this behaviour is a feature request and
not a bug report...

But I may be wrong - so please correct me if so!
Comment by dave (user) - Sunday, 30 April 2006, 12:03 GMT
actually, this seemed to be have been fixed...
now when i just hold the stop button for the typical long-hold time, it shuts off, instead of going back to dir screen and then shutting off.