Rockbox

Tasklist

FS#4906 - Problems with realtime clock

Attached to Project: Rockbox
Opened by Matthias Mohr (aka Massa) (mmohr) - Friday, 24 March 2006, 09:40 GMT
Task Type Bugs
Category Drivers
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Medium
Priority Normal
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

First: I didn't boot the original firmware for months and my bootloader is v5!
So it's _NOT_ the bug that the original firmware changes the year...

Since it's possible to add the clock to the WPS screen, I added it to my WPS
and since then I noticed, that it often shows the wrong year (1999)!
Day, Month and time is correct, only the year is suddenly wrong.

Until now I was unable to find out when it happens exactly, but it seems that
some operations shifts my year...

When I notice it and go to the date/time settings, they are also not very
helpful as they then always show "2000-01-01 00:00:00" instead of the current
date/time (the WPS screen still shows the correct time, the correct day and
correct month - only the year is wrong!)

Does somebody else recognize this?
If yes, did someone find out when it happens exactly?

Maybe it has something to do with the USB connection!?
I just plugged in my device via USB and unplugged it then again and the year
shifted in the WPS display!
This task depends upon

Closed by  Daniel Stenberg (bagder)
Monday, 10 April 2006, 09:58 GMT
Reason for closing:  Works For Me
Additional comments about closing:  Ok, since not even the reported can repeat this anymore we consider it closed!

Please file a new entry if it turns up again!
Comment by Matthias Mohr (aka Massa) (mmohr) - Wednesday, 29 March 2006, 08:13 GMT
I'm not sure if a fix has been made for this -
but I couldn't reproduce the problem lately...

Maybe this is related to it:
Lately I'm unable to charge my device in USB connection mode.
It works in USB charging mode, so I assume my USB port is
still able to deliver enough power to charge my H340.

The charging in USB connection mode did already work in the past!
(and maybe the clock problem vanishes because it does no longer
charge in USB connection mode...)

Loading...