Rockbox

Tasklist

FS#4913 - make backlight on first keypress work with LCD remote

Attached to Project: Rockbox
Opened by David Rothenberger (drothenberger) - Friday, 24 March 2006, 17:59 GMT
Task Type Patches
Category Remote
Status Closed
Assigned To Hristo Kovachev (bger)
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This updates patch 2920 (http://www.rockbox.org/tracker/task/2920) to work with remotes. 2920 added an option to have the first keypress only turn on the backlight when the backlight was off. The problem is that it doesn't consider the source of the keypress or the state of the remote backlight. So, it filtered the first keypress from the remote if the main unit's backlight was off, even if the remote's backlight was on. It would also fail to filter a keypress from the remote when the remote's backlight was off but the main unit's backlight was on.

This patch adds another parallel option to settings for the remote. It filters the first keypress from the remote only if the remote's backlight is off and the first keypress from the main unit only if the main unit's backlight is off.
This task depends upon

Closed by  Hristo Kovachev (bger)
Saturday, 25 March 2006, 19:17 GMT
Reason for closing:  Accepted
Comment by David Rothenberger (drothenberger) - Friday, 24 March 2006, 22:34 GMT
Update the patch to add a stub so the bootloader builds.
Comment by David Rothenberger (drothenberger) - Saturday, 25 March 2006, 04:52 GMT
Just wanted to clarify that without this patch, the remote no longer works with the existing "first keypress only turns on backlight" option enabled. The remote button presses are filtered because the main unit's LCD backlight is off, but remote button keypresses don't turn the main unit's LCD backlight on, so the remote button presses are always filtered out.

Loading...