Rockbox

Tasklist

FS#4924 - 32000 Hz AAC track plays too fast

Attached to Project: Rockbox
Opened by Ben Keroack (bk) - Sunday, 26 March 2006, 18:23 GMT
Task Type Bugs
Category Codecs
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When playing a 66 kbps VBR AAC-LC file with 32000 Hz sample rate in rockbox the file plays too fast (sounds "sped up" with chipmunk voices). The same file plays normally on my PC. I can provide the file upon request.

This is with recent (ca. 060315) CVS on an H120.
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Friday, 24 November 2006, 06:44 GMT
Reason for closing:  Fixed
Comment by Paul Louden (darkkone) - Wednesday, 29 March 2006, 08:40 GMT
Well, AAC isn't really a "supported" codec. It barely works at the moment. I asked some questions, and I'm being told that it's the metadata parser handling things improperly.
Comment by Paul Louden (darkkone) - Wednesday, 29 March 2006, 08:43 GMT
Also, can you provide a sample file that has this problem, it would be extremely helpful in working out a resolution.
Comment by Ben Keroack (bk) - Wednesday, 29 March 2006, 13:11 GMT
I understand that it isn't really supported. I was experimenting to see if at a low enough bitrate it would work realtime. If it played back at normal speed I think this file might come pretty close.

The sample file is attached.
   test.m4a (1.81 MiB)
Comment by Ben Keroack (bk) - Wednesday, 29 March 2006, 16:07 GMT
BTW, saw your comments on IRC. The encoder is iTunes 4.7.1 .
Comment by Carl (spazz) - Wednesday, 15 November 2006, 20:32 GMT
Anybody have a idea where the resolutin of this bug is going along?
Comment by Magnus Holmgren (learman) - Thursday, 23 November 2006, 20:59 GMT
I've changed how Rockbox reads the frequency of the file, so the problem should be solved now. Could someone experiencing the problem please test and add a comment about the result?
Comment by Ben Keroack (bk) - Thursday, 23 November 2006, 21:46 GMT
The 32000hz test file posted here works normally now. Thanks!
Comment by Carl (spazz) - Thursday, 23 November 2006, 22:45 GMT
I also tested my 48kHz aac and they work perfectly now. Thanks alot Magnus :)
Comment by Václav Brožík (pabouk) - Thursday, 23 November 2006, 23:29 GMT
The bug should be fixed by this commit now:
23 Nov 19:46
Magnus Holmgren
apps/metadata.c 1.59
Read frequency in MP4/AAC files from a different place, if available. Should fix the problem with wrong playback speed for non-44.1kHz files.

Confirmed in the forum:
http://forums.rockbox.org/index.php?topic=7416.msg58495#msg58495

Loading...