Rockbox

Tasklist

FS#5059 - Eliminate Silence at End / Beginnings of Songs

Attached to Project: Rockbox
Opened by Anonymous Submitter - Friday, 07 April 2006, 09:03 GMT
Last edited by Marc Guay (Marc_Guay) - Friday, 30 January 2009, 17:15 GMT
Task Type Feature Requests
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

I personally dont like physically removing the silences at the end of my mp3 and aac files, basically because that would make them different from what was on the CD when i ripped the album. However, when i'm shuffling songs it seems out of place to hear the cross-fader simply fading the end of the song to introduce me to silence, or to have to wait before the next song fades in

Winamp's Direct Sound driver does exactly what i would like Rockbox to do. It simply detects if the song(s) in its buffer have anything below a user-specified dB rating, and if they do then it dosen't play it.

I was thinking that since rockbox has a significantly larger buffer (skip protection) than Winamp (2sec max vs 5sec - 30mins max) it would be fairly easy for someone who knew what they were doing to add in this feature, and although it's not as important as developing all of rockbox for other players I think since this request has been waiting for 3 years... you know...

previously requested feature (07 June 2003)
"http://www.rockbox.org/tracker/task/1426"
This task depends upon

Closed by  Björn Stenberg (zagor)
Friday, 30 January 2009, 17:15 GMT
Reason for closing:  Invalid
Additional comments about closing:  Closing all feature requests.
Comment by Timo Horstschäfer (x1jmp) - Sunday, 14 January 2007, 17:42 GMT
I suggest to add a silence detection and cut every silence which is longer than e.g. 5 seconds.
This would also remove the annoying silence between a song and a hidden track. Furthermore it improves real gapless playback.

Removing silence at the end is also a feature the iRiver firmware provides, but rockbox does not.
Comment by Dave Chapman (linuxstb) - Thursday, 02 August 2007, 18:22 GMT
I agree that this would be a nice, but don't agree it's easy to implement.

When playing an album I normally want an accurate reproduction of the original CD (i.e. Rockbox's current gapless playback), but when shuffling and crossfading, it would be nice if Rockbox could not include the in-track silence in the crossfades - I disagree that we always want to play exactly what's in the file (the reason given for rejecting this request).
Comment by Nate Rowe (Spanky) - Sunday, 09 December 2007, 08:28 GMT
I would agree with this but what happens on certain songs when theres silence of 8 seconds or so and it is halfway through the song? Does the rest of the song just get cut off? This would be a pretty complicated code to do right I would imagine.
Comment by Timo Horstschäfer (x1jmp) - Sunday, 09 December 2007, 15:19 GMT
I'd be happy with a "silence shortening". When it detects a silence in a song which lasts longer than e. g. 3 seconds, playback jumps to the next position where music starts again.
Comment by alex wallis (alexwallis646) - Friday, 18 January 2008, 09:29 GMT
Just thought i'd add my voice and say it would be great to see this feature as well. as i do like the option that winamp offers, and if the iriver firmware has this option, adding it to rb would give one less reason to use that orriginal firmware.

Loading...