Rockbox

Tasklist

FS#5105 - Reporting wrong times/bitrates on mono-encoded files

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 12 April 2006, 12:43 GMT
Last edited by Dave Chapman (linuxstb) - Thursday, 25 May 2006, 20:14 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity High
Priority Normal
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When listening to an MP3 file encoded in 64kbps mono on the iRiver H120, Rockbox reports the bitrate as 128kbps and, on screens that show the remaining time of the track, it shows the remaining playing time incorrectly. It shows a time exactly half of the true running time and still decrements every second. When it reaches 0, it starts counting backwards - e.g. "-00:-01" for the remainder of the file. On a 64kbps STEREO file, the bitrate and time display is shown correctly.
This task depends upon

Closed by  Dave Chapman (linuxstb)
Monday, 26 June 2006, 22:56 GMT
Reason for closing:  Works For Me
Additional comments about closing:  Works for me, plus others who have tested.

If you still have this problem with the latest CVS Rockbox, please provide a sample file.
Comment by Dan Everton (safetydan) - Tuesday, 30 May 2006, 10:46 GMT
I can't reproduce this with a build from today (2006-05-06). I'm using a 44 KHz, 64 kbps mono MP3 encoded with lame. Is this still a problem for you? Could you possibly attach a sample MP3 if it is still a problem.

Loading...