Rockbox

Tasklist

FS#5199 - LCD line still active after shutdown

Attached to Project: Rockbox
Opened by PY (py) - Friday, 21 April 2006, 13:17 GMT
Last edited by Nicolas Pennequin (nicolas_p) - Saturday, 29 September 2007, 21:06 GMT
Task Type Bugs
Category LCD
Status Closed
Assigned To No-one
Operating System iPod Mini
Severity Medium
Priority Normal
Reported Version Daily build (which?)
Due in Version Version 3.1
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

The iPod mini 2g LCD display does not respond well to the shutdown command.
Play is pressed until "Shutting down" message appears, then released. Display then *flashes* as it is turning off, but a dim horizontal line often remains lit. If kept in this state too long, the same line will fail to lit properly during regular use of player. Luckily, normal operation was restored after half an hour or so.
This behavior is rather scary and forces me to reboot to Apple firmware to make a proper shutdown.
Please someone have a look at this because risking the health of a player prevents from really enjoying the Rockbox experience.
This task depends upon

Closed by  Nicolas Pennequin (nicolas_p)
Saturday, 29 September 2007, 21:06 GMT
Reason for closing:  Fixed
Comment by Dylan Thurston (dinomight) - Wednesday, 26 April 2006, 21:39 GMT
I too have noticed this behavior on my ipod 4th gen B/W. Only happens every so often.
Comment by Marty (marty131) - Wednesday, 10 May 2006, 06:23 GMT
I had this happen to me on a Nano... only once or twice however. Unfortunately no more details for now.
Comment by Peter Hansen (peterih) - Thursday, 22 June 2006, 11:40 GMT
This also happens on my iPod 4g. I'm using rockbox-ipod4gray-20060622 and the dim line stays on about half the times I shut down the iPod.
Comment by Hugo St-Onge (gorman2001) - Sunday, 27 August 2006, 18:41 GMT
Yes, this occurs on my 4G iPod too (with all builds).
Comment by Matt Jones (soundcheck) - Monday, 09 October 2006, 00:20 GMT
It should be emphasized that when this problem occurs, the line remains visible while running either Apple or Rockbox firmware, as if it was "burned in" to the LCD. Resetting does not get rid of the line.
Comment by Robert Keevil (obo) - Monday, 09 October 2006, 11:32 GMT
This is a bit of a guess (I don't have a B&W ipod to test with), but does this patch help at all?
Comment by Matt Jones (soundcheck) - Friday, 13 October 2006, 04:24 GMT
I'm using a mini2g. The power-ipod.patch did not help. Neither did patch 5489 (LCD shutdown for H300 and Ipod). The "ghost line" problem still happens every time I shut down from Rockbox.

I've also noticed the severity of the problem seems to increase with the length of time the ipod has been left in the shut down state. In other words, if I shutdown from Rockbox, leave the ipod off for a few minutes, and then reboot, the ghost line is very faint and goes away quickly. However, if the ipod has been off for a longer period of time, the problem is exaggerated and takes longer to correct itself.
Comment by Tiago Silveira (dukejeffrie) - Sunday, 26 November 2006, 11:41 GMT
I also see a ghost line on my iPod photo. This is a nasty bug because it might damage the hardware. I'm rebooting to apple's firmware everytime and shutting down from there, but that's painful.
Comment by Tomasz Moń (desowin) - Saturday, 13 January 2007, 17:39 GMT
This patch fixes it on my mini 2g, not sure about others, please check if it's correct
Comment by Charles Childers (crc) - Saturday, 27 January 2007, 23:17 GMT
Tomasz, that patch also seems to fix it on my 2G Mini (at least, it has not appeared in the 6 times I shutdown since applying the patch; compared to the line appearing every time prior), thanks!
Comment by Tomasz Moń (desowin) - Sunday, 28 January 2007, 14:50 GMT
added ifdefs, I believe that it'll work under iPods with color display (iPod color and nano)

I have only tested it on mini 2g though
Comment by Tomasz Moń (desowin) - Sunday, 28 January 2007, 15:35 GMT
oops
Comment by Rick (bospaadje) - Wednesday, 31 January 2007, 02:04 GMT
I'm having the same kind of problem with my nano.
Unfortunately, as Mikachu explained to me in #rockbox, Tomasz' patch will not work for colour displays, 1) because lcd-ipod.c has 2 separate parts, one for b&w and one for colour (this produces a compile error for me), and 2) because the colour display has a completely different chip, so this code will most likely not work.

I hope someone will look into this matter, since it might damage hardware, as several people above already mentioned.
Comment by Tomasz Moń (desowin) - Monday, 26 February 2007, 16:38 GMT
This patch shouldn't break anything now, but like before, this fixes it only on grayscale ipods
Comment by Joel Wiegman (jwiegman) - Wednesday, 11 April 2007, 19:15 GMT
Anyone know if/when these fixes will get merged into SVN? They seem like relatively trivial fixes to a rather pervasive problem...
Comment by Shiloh Hawley (gree665) - Friday, 11 May 2007, 20:22 GMT
I am plagued by this one too on my Ipod 4g. If the above fix works, it would be great to get it in the current build.
Comment by Boris Gjenero (dreamlayers) - Monday, 20 August 2007, 02:28 GMT
LCDs need to be driven by alternating current. For example at http://en.wikipedia.org/wiki/LCD it is written that "Both the liquid crystal material and the alignment layer material contain ionic compounds. If an electric field of one particular polarity is applied for a long period of time, this ionic material is attracted to the surfaces and degrades the device performance. This is avoided by applying either an alternating current, or by reversing the polarity of the electric field as the device is addressed (the response of the liquid crystal layer is identical, regardless of the polarity of the applied field)." For another example see http://www.latticesemi.com/lit/docs/generalinfo/Flexible_Power_Up_whitepaper.pdf

In order to keep changing polarity the LCD controller needs to be running. In this case the controller stops running but a charge remains on one line, probably because the controller wasn't properly shut down before power was removed. This constant DC charge damages that line of the LCD.
Comment by Shiloh Hawley (gree665) - Tuesday, 18 September 2007, 18:55 GMT
Could anyone comment on why this patch has not been accepted? I have tested it on the ipod 4th gen grayscale, and it works (for me, anyway). It fixes a very annoying problem.
Comment by Nicolas Pennequin (nicolas_p) - Saturday, 29 September 2007, 17:49 GMT
Here is a patch that uses a different approach for the #defines. I think it's more in line with what's done elsewhere. Also it doesn't generate warnings. If this is the right approach to solve the problem, it would be good to commit it ASAP.

Loading...