FS#5237 - iriver H140 keeps skipping through tracks.

Attached to Project: Rockbox
Opened by Anonymous Submitter - Wednesday, 26 April 2006, 16:23 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I am using the current CVS version 060426-0821 on an iriver H140.

I have found that since I upgraded to today's daily and then to the latest CVS, I sometimes try to skip one track and the unit just starts skipping through all the tracks in the current playlist until I stop it by pressing the skip-back button. I've also seen it happen spontaneously once when changing tracks. It is not 100% reproduceable but I've seen it three or four times today. I'm currently running with a playlist of all_tracks in shuffle mode. There's 3327 tracks. It's all MP3.

I notice that Brandon committed a change to apparently stop tracks skipping with no user interaction so I upgraded to the very latest CVS (after that release) but it is still happening.


This task depends upon

Closed by  Paul Louden (darkkone)
Thursday, 27 April 2006, 13:54 GMT
Reason for closing:  Fixed
Additional comments about closing:  As far as is known, this problem is fixed. Reporter will create new if it\'s not, but it *really* should be.
Comment by Paul Louden (darkkone) - Wednesday, 26 April 2006, 21:31 GMT
Are you sure that the download you got included the change (did you check to make sure the build with his change in it had completed?)
Comment by Guy Davies (guyd) - Thursday, 27 April 2006, 11:43 GMT
Hi Paul,

Pretty sure. I downloaded it a couple of hours after the change was committed. I have to say that I downloaded the latest CVS image for the H120/H140 this morning and so far today I've not experienced the same issue. Whether it's there or not is difficult to say. It was not entirely reproduceable so I can't be sure. As time goes by, I'll get more confident :)


Comment by Paul Louden (darkkone) - Thursday, 27 April 2006, 11:46 GMT
Alright, let me know if you can't or can't get it to happen in the next 24 hours. I'd like to close this, but I'd like to be sure it's fixed first. :)
Comment by Guy Davies (guyd) - Thursday, 27 April 2006, 13:46 GMT
Hi Paul,

I've been trying (honestly ;-) to cause the problem to recur but have been unable to do so. I suggest closing the bug and, if the problem recurs, I'll open a new bug.