Rockbox

Tasklist

FS#5264 - System Freeze: iPod Photo 60GB

Attached to Project: Rockbox
Opened by Jeff Elkins (JeffElkins) - Monday, 01 May 2006, 03:08 GMT
Last edited by Nils Wallménius (nls) - Sunday, 08 July 2007, 11:30 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System iPod 4G Color
Severity High
Priority Normal
Reported Version
Due in Version Version 3.1
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

System freeze on playback: iPod 60GB Photo using 4/30/06 CVS.

After 30 or so minutes of playing the system freezes. I tried plugged in (USB - A/C) and running off battery. Highly reproduceable here.
This task depends upon

Closed by  Nils Wallménius (nls)
Sunday, 08 July 2007, 11:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  This has been fixed by amiconn's recent changes to the clock setup code.
Comment by Paul Louden (darkkone) - Monday, 01 May 2006, 03:48 GMT
You haven't included steps for reproducing. For example, is there any particular setting that causes this? Have you done any experimenting to see what causes this?
Comment by Jeff Elkins (JeffElkins) - Monday, 01 May 2006, 13:57 GMT
Mainly I tried plugged in to a/c, usb and on battery. This was also with a cleared config file. No settings applied, no special theme, etc.
Comment by Sean Cribbs (mojohand) - Monday, 01 May 2006, 16:38 GMT
Freezing here too as of 5/1/06 build on iPod color 60gb with clean install, cleared config.
Comment by Paul (slip) - Monday, 01 May 2006, 20:17 GMT
Same problem on 4G Grey Ipod. I get regular system feezes
Comment by Jeff Elkins (JeffElkins) - Monday, 01 May 2006, 23:21 GMT
>>You haven't included steps for reproducing.

I thought about this, wondering if it was mp3 bitrate. So I queued up both 128 and 192 mp3s. No difference, both freeze after 30 or so minutes.
Comment by Greg Anderson (icowboyup) - Tuesday, 09 May 2006, 19:55 GMT
Same here iPod Photo 60gig. Seems completly random but happens often.
Comment by mede (mede) - Wednesday, 10 May 2006, 08:04 GMT
have the same problem with my ipod photo 30G

if iam hearing sound the system freeze totaly after some minutes and
i have to reboot the ipod.

i am not sure but in older versions of rockbox i had no so problem.
Comment by Jeff Elkins (JeffElkins) - Wednesday, 10 May 2006, 21:00 GMT
No joy yet with current CVS builds- Freezes every time in under an hour. I've been forced to use retail due to the WAF (wife acceptance factor). Is this being worked on by developers?
Comment by Paul Louden (darkkone) - Wednesday, 10 May 2006, 21:02 GMT
Rockbox is currently in feature freeze prepping for the iRiver release. iPod-specific bugs really don't have much priority until then.
Comment by Jeff Elkins (JeffElkins) - Wednesday, 10 May 2006, 21:03 GMT
OK. I'll keep checking back.
Comment by mede (mede) - Thursday, 11 May 2006, 09:03 GMT
rockbox is a cool thing but this bug is very very annoying !
i am about to take a mental demage because i have to reboot my ipod
every 10 minutes ...

please please have a look at this ...


Comment by Paul (slip) - Thursday, 11 May 2006, 10:36 GMT
On my 4G Greys IPOD it seems to be worse when using crossfade, also when shuffling through a large playlist.
Even when I dont use these it still hangs unexpectantly halfway through a song and the only way to recovber is through a reboot.
Comment by Greg Anderson (icowboyup) - Thursday, 11 May 2006, 11:17 GMT
I ran a defrag on my 60gig, promblem is WAY better! Still hangs occasionally but nowhere near as often.
Comment by Patrick (Megamaden) - Monday, 15 May 2006, 10:58 GMT
I watched the same bug on my ipod 60gb color! The System freezes and sometimes the background image of the wps 'fades' slowly out. Then I have to reboot by pressing menu and select.
Comment by ak (clarkgable) - Tuesday, 16 May 2006, 13:44 GMT
this happens to me on my first gen ipod mini. after playing music for about 30 min ( i tried on all of my mp3s so bitrate or anything is not a factor) the ipod will simply freeze and a reboot is necesarry. one time i got a message saying 'failure at 00417' (not exact number but it was similar to that).
Comment by Greg Aluise (galuise) - Thursday, 18 May 2006, 15:23 GMT
I have experienced this phenomena on an 4G Greyscale IPOD. I have used this device (with crossfading) for early music a parties (the non-mixed portion) of a dj set. One thing I have noticed is when you navigate the menus and make playlist changes every 1-3 minutes it tends to ward off the crash. In fact I have been able to pretty reliably prevent the freeze-ups by just navigating to a new menu every so often. Not sure how much help this is, but one thing I can figure: If you are making playlist changes the HardDrive is forced to spin up. I'm thinking it's something to do with the caching / disk spindown.
Comment by Andres Salomon (dilinger) - Saturday, 01 July 2006, 23:02 GMT
This appears to still be happening with the nightly builds; I see it regularly on my 4g greyscale. Quite annoying.
Comment by pablo funes (pablofunes) - Sunday, 16 July 2006, 07:46 GMT
I have a 30G ipod photo. What makes this bug most annoying is that rebooting is difficult. Perhaps bad keys on my iPod? I must try the reboot procedure several times (hold on/off, hold select & menu for 6 sec) until I get it back.
Comment by Paul Louden (darkkone) - Sunday, 16 July 2006, 07:49 GMT
You don't have to do hold on/off. It's not necessary for *just* rebooting your iPod.
Comment by Yves B (spray) - Monday, 14 August 2006, 13:04 GMT
Hello
I also experience complete freeze with my iPod colour/photo 40Gig. It happens randomly after 10 to 60 minutes, even when the iPod is fully charged or connected to the dock. The screen show a part of the display info. Same problem with all standard themes included in the nightly releases. Has to be re-booted. I am never using crossfade and I didn't change anything in the sound features. I am not using playlists. What's the problem ? :((
thanks for your help
Comment by Yves B (spray) - Tuesday, 15 August 2006, 11:40 GMT
I see on all ipod related forums that many peoples have freeze problems with ipods, even 5G. It's not a Rockbox bug at all ! The strange thing is that nobody cares at Apple. They just keep telling people to reboot the ipod :(
My next mp3 player will not be an ipod !
Comment by Woody (Woody) - Thursday, 07 September 2006, 15:14 GMT
This is really disappointing. I bought an iPod photo 60 color because it is supported by Rockbox.
However it doesn't play longer then 20 minutes on a good day.

Now I have to choose between my old Archos or the Apple firmware (that I really
don't like) on my iPod

I know you guys can do magic so I hope it is fixed soon.
Keep up the great work !!!!!!
Comment by Mela Custodio (sessyargc) - Thursday, 14 September 2006, 06:27 GMT
iPod 5G (60Gb), and a recently custom built Rockbox from the repository does not show these issues. This custom build includes several unsupported patches. I'm currently playing the iPod continously for an hour now. Generally playing with most settings and features. Enabled battery_test, using crossfade, used iPod_Control/Music files, ran TagCache while playing an MP3. All of my audio files are MP3 VBRs which I ripped off my own CD collection, properly tagged with EasyTAG, and some tags contains Unicode (which doesn't display properly on the iPod but displays correctly on the simulator). After TagCache, I'm now playing off the cache, and an auto-generated playlist.

Yesterday, before I installed Rockbox I used the Apple firmware and played continously for 8 hours. Played some CNN video podcasts.

Tech details:
downloaded and built CVS (2006-09-12): binutils-2.17, gcc-4.1.1, gdb-6.5
patched: ipod_brigthness_2.patch, menu_buttons.patch, mp4.1.2.patch, peakmeter_margins_20060831-MM.patch, scroll_margins_20060829.patch, select_ipod_memory_2_(senab_sync).patch and unplug.patch
WPS: UniCatcher (needed for my JPop)
removed uneeded files, extraneous languages, unused plugins (ie games, demos, rockdoom, rockboy)
(only issue I encountered was that the bootloader I built did not boot. i used the bootloader from the site and everything was fine)
Comment by Paul Louden (darkkone) - Thursday, 14 September 2006, 09:16 GMT
Seeing as this bug was reported for the iPod Photo, which is a 4th generation iPod, it shouldn't be happening on a 5G.
Comment by Mark Taylor (skymt) - Saturday, 16 September 2006, 14:32 GMT
I'd just like to add my iPod to the list of crashers. 1G mini, yesterday's build, freshly formatted. Like posters above, activity (such as navigating menus) seems to prevent crashing. Otherwise, I get 10-15 minutes. It doesn't seem related to settings or themes.
Comment by Mark Taylor (skymt) - Saturday, 16 September 2006, 14:48 GMT
Never mind the workaround. I just had a crash around 10 seconds after using the menus. Still working on a cause.
Comment by jim (wirerydr) - Monday, 18 September 2006, 21:07 GMT
I can confirm the same thing happens with my 60GB 4G photo. Playing FLAC files, though, not MP3s. Both using playlists, and direct track selection. Seems to happen anywhere from 2 minutes to 30 minutes after starting playback, but it is definitely repeatable, and predictable. Just seems to be non-specific to any settings I can pin down.

Tried 3 CVS'ed firmwares each about a month apart in age, with the most recent being CVS-06-06-09.

I thought of trying a 4th, newer firmware, but based on other recent comments, I'm guessing it won't be fixed as-of-yet...
Comment by Gene Sweeney (agile_one) - Tuesday, 19 September 2006, 00:36 GMT
Don't know if this will be helpful or not, but I've had various RockBox builds on a 4g 60 gb Photo for over a month. All have frozen, requiring reboot to get out of, but with varying periods of normal operation. I use no eq, 30s anti skip, no crossfeed, have tried directory cache on and off, and use a basic wps (boxes).

fwiw, the best runtimes (hours rather than minutes) have been with a 9/8/2006 build, which I have gone back to. The absolute worst freezing and even inability to boot experiences have been with 9/16 and 9/18/2006 builds - they are completely unusable.

Perhaps this information will be helpful in figuring out what is happening on the 4g color/photos.
Comment by Adam Gashlin (AdamGashlin) - Wednesday, 27 September 2006, 21:31 GMT
I experienced fairly regular crashing on my 60 GB iPod Photo, but it was more common when playing more CPU intensive formats, like MP3 or SID. I saw it recommended that I should try disabling frequency scaling (remove the #define HAVE_ADJUSTIBLE_CPU_FREQ from config-ipodcolor.h), I tried this and I have not experienced a crash since.
Comment by Kyle Eck (youngmecca) - Wednesday, 04 October 2006, 19:11 GMT
Good to hear someone is having some success with this! Would the fix you described work on the 4g grayscale ipods as well? And if so, would you mind detailing the fix a little bit?
Comment by Adam Gashlin (AdamGashlin) - Wednesday, 04 October 2006, 19:37 GMT
makeage has a thread about this here:
http://forums.rockbox.org/index.php?topic=6357.0
He has a 4g grayscale iPod and it works fine for him. Battery life takes a hit, but you must ask yourself if you want to run for two more hours or reboot every 20 minutes...
I have a patch here:
http://www.rockbox.org/tracker/task/6095
That fixes frequency scaling on my photo (several days with no crash), but mikeage had no such luck with it on his grayscale.
Comment by Marcus Williams (sparky) - Monday, 27 November 2006, 17:02 GMT
(found this just after submitting a bug regarding freezes on a 4g)

After installing the cpufreq path build on my 4g it appears that the freezing has gone (or at least I've had no freezing for the last hour or so).
Comment by Steve Bavin (pondlife) - Wednesday, 21 March 2007, 12:23 GMT
Please can anyone who's had this problem try the latest bootloader and build, then report back if they still have freezing issues?

If it's all quiet, I'll close this bug.
Comment by jim (wirerydr) - Wednesday, 21 March 2007, 16:02 GMT
I will. I've got old stuff on my iPod so let me load the latest bootloader/build, and give it a spin for a day or so, and I'll report on how it goes....
Comment by Adam Gashlin (AdamGashlin) - Friday, 23 March 2007, 15:44 GMT
I know you asked for a report if there are still issues, but I'd like to report that I've been running it for a few days now (60GB Photo) and experienced no freezes.
Comment by Peter Cook (maytag) - Sunday, 22 April 2007, 20:44 GMT
I'm still having issues. Hardware is an iPod 60GB Photo. Based off this thread I installed the latest daily build and immediately started having freezes immediately after startup (<5 minutes). Thinking I might have had old gunk I deleted my .rockbox directory and reinstalled using the latest daily, latest fonts, and uninstalled and reinstalled the bootloader. This led to a situation in which Rockbox doesn't even boot most of the time (maybe 1 out of 5 tries). Thinking it might still have something to do with old stuff lying around I opened up the latest version of iTunes and did a restore on the iPod with their latest software, set all the settings to not automatically update anything, then loaded into disk mode and reinstalled Rockbox with 4-22 daily, fonts, and bootloader. I am having the same problem, being unable to load into Rockbox.
Actually, the first time I started it Rockbox did load, however it froze after ~2 minutes and I have been unsuccessful at getting it back running again.
After restoring to my last known good build, a bleeding 070308 build with the COP11 patch before it was committed, Rockbox immediately loads and I have no further issues. There are still intermittent crashes characteristic with the stability reported during the COP11 patch development (somewhere between 1-8 hours with no consistent pattern). At least it works.
So, to answer the question, the latest bootloader and build cause major issues on my pod.
Is there anyway I can take better logs/low level data to try and backtrace the crashes? I'm not sure if there's a plugin to do that or not. Let me know if there's any way I can help--my coding is not up to the level of this project, but I'm fairly proficient at computers in general.
Comment by Adam Gashlin (AdamGashlin) - Monday, 23 April 2007, 14:52 GMT
I have been experiencing freezes again as well, I haven't gone back to see when this began yet. No apparent problems booting, but the same sort of random freezing behavior we used to see.
Comment by Chad (Spinalcold) - Wednesday, 30 May 2007, 02:46 GMT
I'm having mine lock up and display "Data Abort" as soon as I try to play a song. All the plug-ins work fine though.
Comment by Salacious Twit (Walter_Sear) - Monday, 04 June 2007, 23:11 GMT
This 'data abort at XXXXXXX' problem has been plaguing me for months - rockbox is completely unusable on my 60 gig ipod :/ Unfortunately, I no longer have a build that works at all.

Unless anyone has a better suggestion, I'm replacing the original apple bootloader and going to try and figure out how to use >gulp< itunes.
Comment by Salacious Twit (Walter_Sear) - Monday, 04 June 2007, 23:14 GMT
To clarify - my experience is the same as the one that chad describes.
Comment by Steve Bavin (pondlife) - Tuesday, 05 June 2007, 06:54 GMT
Chad and Salacious. Sounds very much like you need to update your bootloader to the latest one, then put the latest SVN build on.

This particular issue refers to random freezes after a while, not immediate data aborts.
Comment by Chad (Spinalcold) - Tuesday, 05 June 2007, 12:50 GMT
Thanks Steve. I didn't realize there was a new boot loader as well as a new build.
Comment by Salacious Twit (Walter_Sear) - Thursday, 07 June 2007, 00:45 GMT
thanks - I'll try that and report back

Loading...