Rockbox

Tasklist

FS#5287 - Music playback pauses while creating root.m3u

Attached to Project: Rockbox
Opened by Tobi (t061) - Wednesday, 03 May 2006, 21:07 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Here's a little problem I have on my AJR 20:

When I create the root.m3u playlist with over 3000 entries, the music playback stops after a while until the playlist is complete. Then it is continued. I think the problem is that the playback buffer is not filled during playlist creation.

A minor workaround could be: fill the buffer automatically when the user calls the playlist creation routine (especially for root.m3u).

But generally I think that the priorities should be changed, so that the playlist creation is interrupted by a playback buffer refill. :)
This task depends upon

Closed by  Tom Ross (midgey34)
Monday, 05 March 2007, 03:31 GMT
Reason for closing:  Out of Date
Comment by Tom Ross (midgey34) - Tuesday, 06 February 2007, 23:54 GMT
Is this issue still valid? The new scheduler should make music the priority and this report was when the old scheduler was in use. Please try a current build.

Loading...