Rockbox

Tasklist

FS#5294 - Quick exit for menu screen

Attached to Project: Rockbox
Opened by Alistair Marshall (amar) - Friday, 05 May 2006, 18:44 GMT
Last edited by Paul Louden (darkkone) - Wednesday, 07 June 2006, 14:21 GMT
Task Type Patches
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

press play in the menu and it will quit to the previous screen (I have been wanting this for a while, not sure if it counts as a bug though)

Though ATM it is only set up for H300 and H100, it just needs button asignments for the other targets
This task depends upon

Closed by  Steve Bavin (pondlife)
Friday, 02 March 2007, 10:22 GMT
Reason for closing:  Out of Date
Additional comments about closing:  I believe the root menu UI changes have superceded this patch. Re-open if I\'m wrong!
Comment by Dominik Riebeling (bluebrother) - Friday, 05 May 2006, 18:54 GMT
thinking of the button assignment in the menu on my h120 I think it's a bit strange Play doesn't do anything and Stop goes one level back. Similar to the file browser I think it would be good (and somewhat consistent) to have it the same in them menu:
- Play to return to wps
- Stop to stop playback
- Left to go a level up (as it already does)
Comment by Alistair Marshall (amar) - Friday, 05 May 2006, 19:30 GMT
- Play to return to wps (this is what the patch does)
- Stop to stop playback (personaly I would like the oposet, stop to take you up one level but it doesn't bother me)
- Left to go a level up (as it already does)

amar aka Pi
Comment by Alistair Marshall (amar) - Tuesday, 16 May 2006, 14:08 GMT
Hi updated it a fair bit, now it should exit from all parts of the menu (including browse plugins etc)
Please test/post comments thanks
(as before it is atill only maped for the H300 and H100 main unit but adding remot and other targets should be simple
Comment by Dave Chapman (linuxstb) - Tuesday, 16 May 2006, 14:59 GMT
Following the discussion in IRC, my suggestion would be to do the following:

1) Implement a "quick exit" button in the menus - this would (where possible) be the same button used to enter the menu. So for example, on the h1x0 it would be BUTTON_MODE, and on the ipods, BUTTON_MENU.

2) Make the PLAY button resume playback (or take the user to the WPS) in more places in Rockbox - an extension of this patch could be used to implement that in the menus.

i.e. don't try and mix the two features.
Comment by Alistair Marshall (amar) - Tuesday, 16 May 2006, 16:31 GMT
Thanks

OK I have changed the assignments to the same button used to enter the menu and added support to all platforms however the ipods use BUTTON_MENU in the colour picker and in select.h and I don't know what should be used instead. I _think_ remote support should be working now.

I only have an H300 <no remote> so if others could test the other platforms I would be grateful
Comment by Alistair Marshall (amar) - Wednesday, 17 May 2006, 16:15 GMT
Now implemented part 2 of your suggestion, now when you quit the menu it always returns you to the WPS if music is playing and the file tree if no music is playing.

Press play, if no music is playing it resumes play list, then does a quick return.
Press stop, it stops current playback
Press menu, does a quick return

Buttons mapped on other targets based on the mappings in the file tree
Would appreciate it of people could check on other targets particularly the ONDIO (I have a bad feeling about the stop play in the file tree with that one)
Comment by Alistair Marshall (amar) - Friday, 19 May 2006, 15:45 GMT
One more go, I think it covers everything asked for
Still not tested on any other targets!
Comment by Michael DiFebbo (medifebbo) - Sunday, 04 June 2006, 12:04 GMT
Tested on iPod Video 60 GB. The patch applies and builds cleanly, and all functions appear to work as designed.
Comment by Norbert Preining (norbusan) - Monday, 05 June 2006, 22:56 GMT
Hi all!
I have added this patch to my experimental builds for h300, but I don't get any special action. Now I can press the A-B button (Menu button I assume) to get one step up, but pressing "Play" does not jump to the WPS screen. Any ideas about this?
Best wishes
Norbert
(for my builds, see http://www.misticriver.net/showthread.php?t=42675
Comment by Norbert Preining (norbusan) - Monday, 12 June 2006, 18:56 GMT
Here is an updated patch for current cvs (made on 2006-06-12 20:00 +0200).
Comment by Dominik Riebeling (bluebrother) - Monday, 12 June 2006, 23:32 GMT
Similar as suggested on the mailing list, it would also be nice to have
- press rec (short) to enter the playlist. Rockbox is playlist based, and atm switching / showing the playlist is a bit clumsy -- rec doesn't do anything at all atm.
- press rec (long) to enter the recording screen. Not to any importance to me as I seldomly use recording, but it would be nice, and I guess really useful for the users that use recording frequently.
I think this would make the button behavior even more consistent.

(the above does of course only apply on targets with a dedicated rec button, in my case h120)
Comment by Simon Menzel (Rincewind) - Tuesday, 13 June 2006, 01:13 GMT
@bluebrother: I suppose this should be a different task (or maybe two) as it is an addition to wps and not to the menu handling.
Anyway here is my patch for "press rec (short) enters current playlist:

Comment by Dominik Riebeling (bluebrother) - Tuesday, 13 June 2006, 07:46 GMT
Ricewind: I think this is somewhat related to this task as I thought also on handling it from within the menu and file browser -- mainly having toggle buttons for the playlist, so mode toggles the menu, rec the playlist, play the wps. Moving and selecting is completely handled by the "joystick" (haven't looked on this for other targets than h100 yet).
But you're right, it doesn't only affect the menu screen so it isn't related only to this task. Maybe we need a new task "make button handling more consistent" if we want to cover all this ideas in a single task (or two different tasks ;-)
Comment by Robert Kukla (roolku) - Friday, 16 June 2006, 13:45 GMT
I only just noticed this patch and I love it. The only problem I have found with menu_buttons_NP20060612.patch so far is that if you enter a menu from the radio screen and press the play button there, it will bring you to the WPS as expected with audio resuming and radio stopping - however the peakmeter is not working and I haven't found a way to make it start work again without a reboot. Cheers, Roolku
Comment by Alistair Marshall (amar) - Tuesday, 18 July 2006, 16:20 GMT
OK as the freeze is over i have updated against CVS again and added the fade(o); a nd bookmark fuction calls that were missing. Please check on other other targets (particularly ONDIO still not shure if i got it correct here
Comment by Michael DiFebbo (medifebbo) - Tuesday, 18 July 2006, 19:12 GMT
I've noticed one small bug. When in the menu system, the play button returns to the WPS, but it also pauses playback, which I believe is unintended. I have tested this on an iPod 5g using the most recent patch above. I have not yet had a chance to test on any other target.
Comment by Alistair Marshall (amar) - Tuesday, 18 July 2006, 19:20 GMT
This doesn't happen on my h300, so without an ipod to playwith, i can't think of any way to fix this.
Anyone?
Comment by Ryan Sawhill (ryran) - Wednesday, 19 July 2006, 01:58 GMT
Oh wow. I always wondered about that, but just assumed it was intended.. for some reason.
Comment by Michael DiFebbo (medifebbo) - Thursday, 20 July 2006, 12:24 GMT
I've tested this patch on Archos platforms on the sim, and it compiles and appears to work fine on all platforms except for the Archos Player, which breaks the compiler with the following error:

menu.c:209: error: `BUTTON_OFF' undeclared (first use in this function)
menu.c:209: error: (Each undeclared identifier is reported only once
menu.c:209: error: for each function it appears in.)


Comment by Michael DiFebbo (medifebbo) - Saturday, 22 July 2006, 14:39 GMT
This patch corrects the problem noted in my previous comment.

This patch now compiles on all platforms.
Comment by Linus Nielsen Feltzing (linusnielsen) - Tuesday, 25 July 2006, 13:33 GMT
I liked this patch for a while, until you started adding more stuff than just the quick exit.
Comment by Simon Menzel (Rincewind) - Tuesday, 25 July 2006, 16:23 GMT
just a note: this patch makes it very hard to enter the id3-info screen from the wps (on irver with PLAY + A-B). you have to release both buttons at the exact same time, otherwise the screen is only shown for the time the buttons are pressed and is exited directly afterwards.
Comment by Dominik Riebeling (bluebrother) - Tuesday, 25 July 2006, 17:03 GMT
on my h120 I usually access the id3 screen via the wps context menu. I wasn't aware there is this button combination. Is this intended? Also, I have this "very hard" behaviour also without this patch -- when holding A-B too long the quick screen gets triggered sometimes, when holding play a bit too long it returns to wps. Also, sometimes the status bar (enabled, disabled in wps) doesn't show up correctly.
Accessing the id3 screen from the context menu (as I'm used to) works without any problems.
Comment by Simon Menzel (Rincewind) - Tuesday, 25 July 2006, 17:47 GMT
yes, this button combo is intended. I only discovered it by examining the gwps.c source, I didn't know it for a long time. But it is very handy to take a short look at your replaygain values.
If my problems aren't related to your patch, then I suppose I just had more shaky hands today than usual (I was using a build without your patch for some time up to yesterday).
Comment by David Rothenberger (drothenberger) - Wednesday, 16 August 2006, 22:56 GMT
I updated the patch for CVS HEAD with all the new button changes. I modified the iriver h1x0-h3x0 keymaps so that
1. Main unit ON will start playback in the menu.
2. Main unit OFF will stop playback in the menu.

The updated keymap generates ACTION_WPS_STOP and ACTION_WPS_PLAY for OFF and ON. I modified menu.c to recognize those actions. I'm not sure whether this is appropriate or whether ACTIONs should have been added to action.h (e.g., ACTION_MENU_PLAY, ACTION_MENU_STOP).

I did not adjust any other keymaps.

NOTE: In CVS HEAD, there is no way to move up a level in the list tree using the remote. I submitted patch 5830 to correct that problem. I did not include that fix in this patch.
Comment by David Rothenberger (drothenberger) - Monday, 21 August 2006, 17:07 GMT
Updated for CVS HEAD. Verified it builds for all targets and sim targets.
Comment by Ryan Sawhill (ryran) - Sunday, 07 January 2007, 07:25 GMT
any chance someone more knowledgeable than me could fix this bad boy? it's pretty out of synch...
Comment by Alistair Marshall (amar) - Sunday, 07 January 2007, 10:40 GMT
I gave up trying to keep this synced when it became apparent that it was not going to be included in CVS. Currently my computer can't compile rockbox but this may give me a reason to try again if i have some spare time.
Comment by Simon Menzel (Rincewind) - Sunday, 07 January 2007, 13:58 GMT
I would also like to see an update of this useful patch!
The last time I used it I removed some code from the patch that wasn't needed with the new button action system but I don't remember if this was before the last update here or not. Unfortunately I don't have those sources anymore. If you don't get around to it in the next time I might update this patch (only if it is not very difficult and I need to have the time, too)
Comment by Norbert Preining (norbusan) - Monday, 08 January 2007, 15:20 GMT
Here is a sync against todays cvs. This is more or less the patch I am using in my build. Only compile time tested.
Comment by Brock Norman (mightybrick) - Thursday, 25 January 2007, 03:21 GMT
Hunk error with today's SVN. Hunk#1 failed at 509.
Comment by Jon (ace214) - Monday, 05 February 2007, 01:00 GMT
sync
Comment by Jon (ace214) - Monday, 05 February 2007, 02:32 GMT
sorry- typo. didn't compile. this one works.
Comment by Paul van der Heu (paulheu) - Saturday, 10 February 2007, 18:11 GMT
The patch is seriously broken against SVN right now..

Loading...