Rockbox

Tasklist

FS#5449 - 4th gen photo iPod responsivity

Attached to Project: Rockbox
Opened by Marc-Andre Moreau (Aghaster) - Sunday, 28 May 2006, 00:34 GMT
Last edited by Daniel Stenberg (bagder) - Monday, 30 July 2007, 08:36 GMT
Task Type Bugs
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod 4G Color
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

It seems that the 4th gen photo iPod has bad responsivity. It happens on my ipod and on other people's iPod i've asked about the problem, but it seems to work fine on other iPod models (iPod mini). What is happenning is that keys aren't always correctly inputted, for example i can try to close my ipod but i'll have to try more than once pressing play before it really works. Or i could simply have to press several times play in other to pause playback, or it can happen with left and right arrows when i try to change songs. In other words, responsivity is bad. This is probably a problem to be fixed in the driver for the 4th gen photo iPod clickwheel.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Monday, 30 July 2007, 08:36 GMT
Reason for closing:  Out of Date
Additional comments about closing:  No response
Comment by Dave Chapman (linuxstb) - Sunday, 28 May 2006, 07:42 GMT
I have no such issues on my Photo.

Do you have the "First keypress enables backlight" option turned on?

Also, are you sure Rockbox is losing keypresses, and not just taking its time to perform the action?
Comment by Paul Solecki (probedb) - Friday, 11 August 2006, 09:17 GMT
Should I add a bug for the nano as well?

I posted about this bug on the forum and several people have it. I've tried disabling all the 'first keypress..' type stuff as recommended to no avail.

This morning it took 5 presses to get it to go into pause, other times it does it straight away but is very annoying.
Comment by James Munro (xen) - Thursday, 22 March 2007, 12:19 GMT
I can also confirm this problem on my 5G (video) iPod. I worry however, that the lack of response from the player is just due to the speed that Rockbox can run effectively on the iPod. I believe that it is something that will improve in time, however if there's anything that can be done to improve the situation, I'm in on it!
Comment by Jonathan Gordon (jdgordon) - Sunday, 15 July 2007, 07:57 GMT
can this be closed with recent updates?

Loading...