Rockbox

Tasklist

FS#5466 - Exiting TagCache may trap you inside a directory

Attached to Project: Rockbox
Opened by Jonas Häggqvist (rasher) - Tuesday, 30 May 2006, 20:19 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If you haven't generated tagcache, and switch from TagCache to fileview after having attempted to use tagcache, you will find yourself in a directory you can't exit from.

Steps to reproduce:
1. Go into a directory
2. Switch to ID3 Database view
3. Attempt to enter a virtual folder, a splash will tell TagCache not ready (with another splash below it, don't know what that says)
4. Switch back to file view

Now you can't exit the directory by pressing left on the joystick (or whichever button is used for this)

Exists (at least) on H120 target and H300 sim.
This task depends upon

Closed by  Hristo Kovachev (bger)
Wednesday, 12 July 2006, 06:51 GMT
Reason for closing:  Accepted
Additional comments about closing:  In CVS as of today
Comment by Jonathan Gordon (jdgordon) - Wednesday, 31 May 2006, 04:16 GMT
ok, its a simple fix.. but im not 100% of the reporcussions of the fix...
line 626 of tree.c needs to be changed from if (tc.dirlevel == 0) to if (!strcmp(currdir,"/") && tc.dirlevel == 0)
the problem is with this the tc.dirlevel can become negative which may cause other problems?? my limited testing on the h300 sin didnt show any problems with this fix tho..
Comment by Dominik Riebeling (bluebrother) - Tuesday, 11 July 2006, 19:39 GMT
I was just able to reproduce this behaviour on h120 target (060710 cvs build) with generated tagcache, so it seems it's not fixed. Should be done before 3.0 ...

Loading...