Rockbox

Tasklist

FS#5472 - ipod 64MB memory

Attached to Project: Rockbox
Opened by Petey Leinonen (orfax) - Wednesday, 31 May 2006, 08:44 GMT
Task Type Patches
Category Operating System/Drivers
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This patch remaps the full 64MB memory available on the 60GB ipod video. This will make all 64MB available to rockbox.
This task depends upon

Closed by  Daniel Stenberg (bagder)
Saturday, 19 May 2007, 14:35 GMT
Reason for closing:  Fixed
Additional comments about closing:  version three used, slightly edited and now committed
Comment by Dave Chapman (linuxstb) - Wednesday, 31 May 2006, 09:07 GMT
Nice work on figuring out the change needed. Can you update your patch to also include the required change to tools/configure which allows the user to specify the amount of RAM available?

But IMO we don't want to apply this patch to CVS and add yet another build to the system - the desirable solution is a single 5g build that will detect and use all available RAM.

The issue with that is that currently the codecs and plugins are compiled and linked in order to be loaded to fixed memory locations at the end of RAM. This approach of course fails when the end of RAM is not known at compile-time.

A solution would be to reorganise the memory allocation so that the codecs and plugins are located at the start of RAM.

But getting Rockbox working correctly with 64MB RAM in the first place is a good start.
Comment by Petey Leinonen (orfax) - Saturday, 03 June 2006, 01:41 GMT
linuxstb, done. File attached is the modified patch.

As there are no plans to apply it to CVS I haven't spent too much time modifying configure. Now it has another build option (22) which is the ipodvideo 64MB build. If done properly I would have written a function to ask the user which memory model they want.
Comment by Dave Chapman (linuxstb) - Saturday, 03 June 2006, 08:28 GMT
As you say, an extra build option is enough. It's just to help those people who want to use your patch to compile their own 64MB builds.
Comment by Thomas Paul Diffenbach (tpdiffenbach) - Thursday, 08 June 2006, 01:19 GMT
I installed the second version of the 64 MB patch: http://www.rockbox.org/tracker/?getfile=11753
configured build 22, and built.

However Menu|Info|Rockbox Info still shows a < 32 MB buffer (specifically, 28.843MB).

Is this a bug in the displayed buffer size, a bug with the patch, or my error?

Thanks.
Comment by Thomas Paul Diffenbach (tpdiffenbach) - Thursday, 08 June 2006, 03:02 GMT
New build directory fixes this for me. Please ignore previous comment.
Comment by Anders Hunstad (AndersHu) - Wednesday, 02 August 2006, 22:38 GMT
I think there is something wrong with this patch, it does not work well with the resent change of compile optimization of libmad.
Playback of mp3 files fails after some time of playing (usually minutes of play but I have observed the error as late as an hour of play).
Comment by Petey Leinonen (orfax) - Thursday, 03 August 2006, 11:03 GMT
Anders,

do you have *any* other patches applied as well?

I have a build that includes the change to libmad optimization and have played mp3s heavily over the previous week without any problems.
Comment by Petey Leinonen (orfax) - Thursday, 03 August 2006, 12:34 GMT
I've updated the patch to adjust the build option to 24 as a couple of new builds have been added some time after the 24 July 2006.

Anders, try again with this patch (though I don't think this will fix your problem). Also can you please look at Info/Rockbox Info and tell me what your buffer is set to.
Comment by Ryan Sawhill (ryran) - Thursday, 03 August 2006, 12:41 GMT
Yeah--I've compiled a new build for myself since the libmad commit with not problems....
Comment by Daniel Stenberg (bagder) - Thursday, 03 August 2006, 16:41 GMT
I would rather see this using the already present configure prompt asking for memory size after you select the target device. We already have numerous (Archos) players with selectable memory size to build for and IMHO, it would make sense to use the same approach for this build - if it is to be committed.
Comment by Michael DiFebbo (medifebbo) - Thursday, 03 August 2006, 19:03 GMT
Daniel, is something like this what you had in mind?
Comment by Michael DiFebbo (medifebbo) - Thursday, 03 August 2006, 19:25 GMT
Actually, this is probably a much better way to do it:

Comment by Daniel Stenberg (bagder) - Thursday, 03 August 2006, 20:08 GMT
Yeps, that's exactly how I meant it!
Comment by Petey Leinonen (orfax) - Friday, 04 August 2006, 02:40 GMT
bagder,
just an explanation why I did it the way I did. As linuxstb and Llorean had already stated that they did NOT want to commit this, preferring to detect how much memory is available instead, I did the simplest change I could. I had planned to use the memory prompt, and may have changed the patch later if I was having to do many changes because of new platforms.

Nice change Michael.
Comment by Petey Leinonen (orfax) - Friday, 04 August 2006, 02:55 GMT
I've made a small change to the patch to add the relative path from the rockbox root directory for the changes to the configure script. This way we can run patch from the rockbox root without falling over.
Comment by Daniel Stenberg (bagder) - Friday, 04 August 2006, 07:14 GMT
Well, this way it is also more likely to survive further changes of configure
Comment by todd (mrmagic526) - Saturday, 09 September 2006, 04:56 GMT
I think this is broken now.... I used the select_ipod_memory_2.patch and it's not letting me view jpg's now. It says incompatible model or something like that... without the patch it works fine. It compiles without errors...
Comment by todd (mrmagic526) - Sunday, 10 September 2006, 20:49 GMT
Also you get codec errors when trying to play music. I tried looking at the code but I'm clueless. I downloaded a clean cvs and patched it with select_ipod_memory_2.patch and 30 gig compile works fine. Compile a 60 gig and I get those errors on my 60 gig ipod video.
Comment by Chris Banes (senab) - Monday, 11 September 2006, 14:51 GMT
Resync, should be working as before now ;)
Comment by Petey Leinonen (orfax) - Monday, 18 September 2006, 03:18 GMT
Cheers senab,

I came to update the patch and noticed your changes.

Thanks.
Comment by Chuckles (Chuckles) - Sunday, 08 October 2006, 03:29 GMT
I'm still getting the codec failure with the latest patch
using daily build20060829
also with album art, bmp resizing and scrolling margins patches
Comment by Chuckles (Chuckles) - Sunday, 08 October 2006, 03:58 GMT
sorry, daily build above is 20061006 (was reading a patch date before :-) )
Comment by Petey Leinonen (orfax) - Sunday, 15 October 2006, 02:26 GMT
Chuckles,

I had no problems (related to the memory patch) compiling and using a build from the 6th October. There may have been a change to the Rockbox source since this date that may have broken the patch. I'll have a look in a couple of days and report back. I'm trying to sort out another issue at the moment (not related to this patch).

I just want to confirm that you are using a 60GB 5th gen ipod (video ipod)
Comment by Chuckles (Chuckles) - Sunday, 15 October 2006, 02:42 GMT
Yep, i'm using a 60GB video ipod

I haven't tried again with any recent daily releases, i'll give it a shot with only the memory patch
Comment by Petey Leinonen (orfax) - Monday, 16 October 2006, 11:18 GMT
Just compiled and used this patch fine. Source is "20061014 01:33", only patch is this one.
Comment by Chuckles (Chuckles) - Thursday, 16 November 2006, 01:53 GMT
Ok i've tried again with fresh daily source

rockbox: daily-20061115
select_ipod_memory_2_(senab_sync).patch
scroll margins: 20061114
bmp_resize: v0.99.6-MM.20061102
album art: v5.2_20061114

patches applied in above order

and i still get the same codec failure
Comment by Chuckles (Chuckles) - Thursday, 16 November 2006, 02:23 GMT
I just rebuilt rockbox: daily-20061115 with only select_ipod_memory_2_(senab_sync).patch and i still get the codec failure

(and i can confirm again that i'm using an ipod 60gb, the drive holds 60gb and there is a big embossed 60gb on the back)
Comment by Chuckles (Chuckles) - Thursday, 16 November 2006, 04:39 GMT
Just to test that it wasn't me compiling wrong i grabbed ace241's unsupported build, it also throws a codec error when i try and play a song.

by the way i'm trying to play both ogg and mp3 files

also, i cleared the settings (using rockbox menu) and reset, still wont work
Comment by Chuckles (Chuckles) - Thursday, 16 November 2006, 05:14 GMT
Ok, I started from scratch, wiped all rockbox related files off the ipod and reinstalled and it worked, something somewhere was hanging around between installs

Thankyou all for your ears and apologies for all the posts, (and for anyone with the same issue, do a clean out)
Comment by Petey Leinonen (orfax) - Friday, 17 November 2006, 09:51 GMT
Good to hear you got it going.
Comment by robin (robin0800) - Sunday, 04 March 2007, 19:05 GMT
This Patch Is Now Broken by the latest build has it now been commited?
Comment by David Hall (Soap) - Sunday, 04 March 2007, 20:12 GMT
I believe this will fix it. (I've been wrong before.)
Comment by Robert Kukla (roolku) - Sunday, 04 March 2007, 21:45 GMT
Add ipod video (60GB) as separate build target without extra memory size prompt.
Comment by Petey Leinonen (orfax) - Tuesday, 06 March 2007, 10:26 GMT
Thanks Soap and roolku,

I fixed the patch the other day, and was going to upload the latest changes now, but I see you guys beat me to it.

Loading...