Rockbox

Tasklist

FS#5500 - Playback not working after USB Connect (H300)

Attached to Project: Rockbox
Opened by Ioannis Koutoulakis (Genre9mp3) - Monday, 05 June 2006, 14:46 GMT
Last edited by Alexander Spyridakis (xaviergr) - Monday, 05 June 2006, 14:49 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After disconnecting the player from USB mode (NOT Bootloader USB mode), when trying to play a song, it goes to the WPS but playback never starts... The problem persists until a reboot...
This task depends upon

Closed by  Steve Bavin (pondlife)
Tuesday, 03 October 2006, 10:36 GMT
Reason for closing:  Fixed
Comment by Alexander Spyridakis (xaviergr) - Monday, 05 June 2006, 14:51 GMT
I can confirm this on my H300. After USB mode the player refuses to output sound unless I restart or ROLO.

Strangely this does not happen for H100 though.
Comment by Jerome Vizcaino (PlugZ51) - Saturday, 10 June 2006, 08:46 GMT
Works fine with me.
USB is plugged in, device is mounted, unmounted, unplugged then I can still play songs.
Comment by Ioannis Koutoulakis (Genre9mp3) - Thursday, 15 June 2006, 12:06 GMT
Strange... I still have it (CVS 060615-0347)
Comment by Dominik Riebeling (bluebrother) - Friday, 04 August 2006, 22:16 GMT
This problem recently (after the feature freeze was lifted) arised for me (h120) while I didn't had that problem for a long time. Looking in the audio thread screen shows the codec buffer filled / getting filled but the pcm buffer stays always empty.
Comment by Steve Bavin (pondlife) - Monday, 02 October 2006, 13:17 GMT
Ionannis, Dominik, Alexander - do you still see this problem with the current CVS build? I did a mod during September as part of my voice work that may have resolved this.
Comment by Dominik Riebeling (bluebrother) - Monday, 02 October 2006, 13:33 GMT
Just installed a current build, seems I can't reproduce it anymore. I'm a bit short on time atm so I will recheck in a few days, but afaics it's fixed. \\o/ (Btw, I have a voice file installed but voice disabled -- maybe the installed voice file triggered this in the first place)
Comment by Ioannis Koutoulakis (Genre9mp3) - Monday, 02 October 2006, 21:21 GMT
I can confirm this, too! I cannot reproduce the bug anymore with latest CVS! :) Thanks pondlife!

Loading...