Rockbox

Tasklist

FS#5570 - Voicing causes freeze on music playback

Attached to Project: Rockbox
Opened by Mike Holden (mikeholden) - Monday, 19 June 2006, 13:25 GMT
Last edited by Peter D'Hoye (petur) - Tuesday, 20 June 2006, 09:57 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H300 series
Severity Critical
Priority Normal
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If I enable voicing of any kind, then it causes major problems on my 340, with a daily build from the last couple of days. Currently loaded is CVS-20060619.

First off, no file/dir voicing occurs.

Second off, when I play a music file, although the file loads and the WPS shows correct data, no playback occurs, and the counter sticks at 0:00. Sometimes you will hear a tiny fraction of playback, but nothing more. The unit just stops there. It will respond ok to pause/play, and will respond to stop. However when pressing stop, it gets as far as the Creating Bookmark splash, and locks up completely, needing a hard reset with a paperclip.

After a bit of messing around trying to find which build broke it (it used to work, so I thought) I finally hit on what the problem is - while investigating another issue with voicing, I renamed my english.voice file to stop it being loaded on bootup, and this is totally the cause of the problem. If I rename it back to english.voice, everyting works as expected, but if in rename it to EEEenglish.voice, then file/dir voicings fail, and the unit locks up as described above.

The workaround is obvious (load the file and name it correctly), but this bug will hit any user who wants to voice files and dirs, but who doesn't have an appropriate voice file loaded.
This task depends upon

Closed by  Steve Bavin (pondlife)
Tuesday, 29 August 2006, 09:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  The original problem is resolved - any other voice-related crashes should be logged seperately.
Comment by Steve Bavin (pondlife) - Tuesday, 20 June 2006, 08:21 GMT
I don't know if this is the same bug, but I can reproduce an H300 hard crash this way:

1) Enable .talk clips for files and folders - disable voice menus, as well as crossfade, resume on startup or any of the other "troublesome" options.
2) Restart the device, so nothing is playing.
3) Go to the file browser and press down arrow; it will correctly speak the selected name (via .talk clip).
4) Wait for the disk access indicator to go off.
5) Press down arrow; it will lock up immediately.

How does this recipe work for others?
Comment by Steve Bavin (pondlife) - Tuesday, 20 June 2006, 08:59 GMT
Note also that you need to have directory cache enabled to reproduce this, or no crash will occur.
Presumably this is because having dir cache disabled means the disk will be spun up to read the subdirectory before an attempt is made to play the .talk clip?
Comment by Steve Bavin (pondlife) - Wednesday, 21 June 2006, 07:32 GMT
Sorry to hijack this bug a bit, but just wanted to note that Hardeep's commit ("Wait for voice to complete before stopping playback. Fixes hang when stopping from filetree while voice is playing") doesn't help with the case I mention above.

Michael, do you have Dir Cache enabled? If so, does your problem go away if you disable it?
Comment by Mike Holden (mikeholden) - Wednesday, 21 June 2006, 09:45 GMT
Dir cache is already disabled.
Comment by Hardeep Sidhu (hardeeps) - Thursday, 29 June 2006, 17:00 GMT
Mike: I can reproduce your problem. It's related to having talk clips on your device without a voice file. I'll investigate.

Steve: I cannot reproduce your problem with or without dircache. If it still reproduces for you, please open a new bug with detailed steps and configuration. Please do not continue to hijack this bug as it's a different issue most likely.
Comment by Steve Bavin (pondlife) - Friday, 14 July 2006, 18:36 GMT
Hardeep: Sorry for the delay - been away. No, I can't repro my issue now; it appears to br fixed in CVS.
Mike: Sorry again for hijacking.
Comment by Steve Bavin (pondlife) - Thursday, 03 August 2006, 11:39 GMT
Hi Mike, if you can apply patch 5766 (http://www.rockbox.org/tracker/task/5766) to a CVS build, you should find this has been fixed.
Comment by Mike Holden (mikeholden) - Tuesday, 08 August 2006, 10:24 GMT
Sorry, don't have a build environment set up for the 340, and unlikely to have one for the foreseeable future.

If anybody else can build one, I can test it though.
Comment by Steve Bavin (pondlife) - Monday, 14 August 2006, 11:13 GMT
Hi Mike, there's a build (CVS + patch 5766) attached here. There is a known problem where things can go screwy after changing the voice settings - make sure you close down and restart if you have to do this - I'll look into it in the near future hopefully.

Keep me informed of progress - the patch page above would probably be the best place.
Comment by Steve Bavin (pondlife) - Tuesday, 15 August 2006, 18:03 GMT
Hi Mike, This patch is now in CVS - please try a new build from there and report back here.
Comment by Alan R (alanwarwic) - Friday, 25 August 2006, 09:30 GMT
In setting up a H120 for a blind friend(all talk settings on with a talk clip for every file/directory) I am going to advise her not to do any 'file browsing' while a song is actually playing. The unit hangs in what I am finding are random circumstances (will usually hang withing 2 mins of browsing unit/files etc). Build 15 August 2006

My advice to her will be 'STOP MUSIC BEFORE BROWSING'
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 25 August 2006, 09:35 GMT
Alan,

my advice to you is to always try the latest daily build before commenting on a bug report.
Comment by Steve Bavin (pondlife) - Friday, 25 August 2006, 09:38 GMT
Yes, this was probably fixed on the 23rd August.
Comment by Alan R (alanwarwic) - Friday, 25 August 2006, 13:40 GMT
well no comments here and I was told that this build was the most stable of the bunch.

I wont be at hand to help so am hoping to use the most stable version when th H120 gets passed over the water.

Most users dont use the voice so voice related bugs possibly stay lower profile due to less people shouting 'gimme gimme'
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 25 August 2006, 14:20 GMT
I understand. As you pointed out, our problem is that few people use the voice. It gets even worse when those few users prefer to not use the latest builds, and we get no feedback when we actually do fix things. We have fixed quite a few voice related issues since august 15.
Comment by Alan R (alanwarwic) - Friday, 25 August 2006, 15:41 GMT
I had used the version dated 22nd August but in the hardware forum I was advised to use the 15 August build.

Never used Rockbox before and it did seem sensible advice at the time.

I will put on todays build later.
Comment by Mike Holden (mikeholden) - Tuesday, 29 August 2006, 09:35 GMT
Apologies for not getting back sooner, but I've been away on holiday!

Have now tried a recent daily build, and can confirm that this issue is now resolved. Thanks for the work.

Loading...