Rockbox

Tasklist

FS#5589 - No audio on h120/140 in recording with "Show Recording Screen on Startup" on

Attached to Project: Rockbox
Opened by Alan Martello (putters) - Friday, 23 June 2006, 17:44 GMT
Last edited by Peter D'Hoye (petur) - Saturday, 24 June 2006, 08:09 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Medium
Priority Normal
Reported Version
Due in Version Version 3.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

On h140, set "Show Recording Screen on Startup" to "yes". At startup, displays recording screen immediately and everything is fine EXCEPT I can't monitor audio through the headphones. The level meters are responding and it in fact records just fine, I just can't hear a thing. To actually hear the audio, I need to press "Stop" to go to the "Recording Screen|Recording Settings" screen and then if I go back into the "Recording Screen", everything is fine. This happens with headphones plugged into the remote or plugged directly into the main unit. I am not sure if this is a problem for other platforms other than the iRiver h120/140.
This task depends upon

Closed by  Martin Scarratt (mmmm-)
Thursday, 31 August 2006, 20:13 GMT
Reason for closing:  Fixed
Comment by Peter D'Hoye (petur) - Friday, 23 June 2006, 21:23 GMT
as far as I can see, the code will do the same as a simple sleep(), maybe the problem is related to startup speed?
Comment by Alan Martello (putters) - Friday, 23 June 2006, 21:34 GMT
petur: I absolutely agree with you. I was peeking into the code further and was quickly coming to the same conclusion you were. I ran a test and yes, if I put in a sleep(1) it still exhibits the bug (since it never sleeps) and if I put in sleep(HZ), the bug is gone. I agree that there is something in the HW initialization that is not getting done properly but perhaps is getting cleanup up coming out of the sleep interrupt?

Anyway, the attached patch is my latest version with an #if so it's only used for the IRIVER_H100_SERIES.

I'm willing to try and track this down a little further since it happens EVERY TIME (i.e. 100% repeatable), but I'd need a little guidance in where to look.
Comment by Peter D'Hoye (petur) - Friday, 23 June 2006, 21:37 GMT
ugh, your second patch includes more than you intended I think ;)
Comment by Alan Martello (putters) - Friday, 23 June 2006, 21:43 GMT
Sorry about that, copied the wrong patch file... (the one AFTER the REP patches).
Attached this time is the correct one.
Comment by Peter Olson (Peter200lx) - Sunday, 20 August 2006, 19:50 GMT
I have the same problem. When I had an Archos Recorder this wasn't a problem I believe. But I've noticed it with the iRiver H100.

Loading...