Rockbox

Tasklist

FS#5751 - Make crossfade less pessimistic

Attached to Project: Rockbox
Opened by Steve Bavin (pondlife) - Monday, 31 July 2006, 18:05 GMT
Task Type Patches
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since the audio engine refactoring, the crossfade process is often skipped for no obvious (to the user) reason. The existing code appears to be somewhat pessimistic about the amount of buffered data required to initiate a crossfade. There are various checks for .5s and 3s of data, and I believe the latter to be redundant (and probably the cause of the non-crossfades). This patch simply removes that test and is put here for further testing.
This task depends upon

Closed by  Jonathan Gordon (jdgordon)
Thursday, 03 August 2006, 08:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  .

Loading...