Rockbox

Tasklist

FS#5766 - Fix for various voice-related crashes

Attached to Project: Rockbox
Opened by Steve Bavin (pondlife) - Thursday, 03 August 2006, 16:05 GMT
Last edited by Steve Bavin (pondlife) - Tuesday, 15 August 2006, 17:09 GMT
Task Type Patches
Category Language
Status Closed
Assigned To No-one
Operating System All players
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The attached patch updates playback.c so that the required buffers for a voice codec are initialised even if no voice file is loaded, if thumbnail clips are in use. Without this, attempting to use .talk clips without a voice file will crash. See bug  FS#5570  for details.
This task depends upon

Closed by  Linus Nielsen Feltzing (linusnielsen)
Tuesday, 15 August 2006, 18:01 GMT
Reason for closing:  Accepted
Comment by Steve Bavin (pondlife) - Thursday, 03 August 2006, 16:12 GMT
Here's the patch.
Comment by Steve Bavin (pondlife) - Thursday, 03 August 2006, 17:49 GMT
OK, take 2. This will set up the voice codec if a voice file has been loaded or thumbnails are in use.
Comment by Steve Bavin (pondlife) - Thursday, 03 August 2006, 17:51 GMT
I keep forgetting to attach the right patch... here it is.
Comment by Steve Bavin (pondlife) - Thursday, 03 August 2006, 18:07 GMT
Add the following patch to force a call to audio_set_crossfade when the .talk options are changed. This works a bit better, but still can crash. Unfortunately I don't have time to look further right now.
Comment by Steve Bavin (pondlife) - Tuesday, 15 August 2006, 17:12 GMT
Fixed the above problem and it seems to have been caused by the same bug which causes Ogg Vorbis (and maybe other codec) playback crashes. The attached patch supercedes all above attachments.

Loading...