Rockbox

Tasklist

FS#5775 - splash function backwards hebrew sentences.

Attached to Project: Rockbox
Opened by Shachar (Lamed) - Sunday, 06 August 2006, 11:58 GMT
Last edited by Rani Hod (RaeNye) - Thursday, 28 September 2006, 16:31 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

A Hebrew sentence like:
I have ate a cat

would be splashed backwards, ie:
cat a ate have I

(I assume) the splash function treats every word in the sentence separately, disallowing the hebrew mechanism that is run under the LCD_ functions to invert the whole sentence.
This task depends upon

Closed by  Shachar (Lamed)
Tuesday, 03 October 2006, 00:10 GMT
Reason for closing:  Fixed
Additional comments about closing:  Pay no attention to the man behind the curtain.
Comment by Marcoen Hirschberg (marcoen) - Tuesday, 19 September 2006, 07:45 GMT
I see the problem. Will take a look at it.
Comment by Shachar (Lamed) - Tuesday, 19 September 2006, 19:22 GMT
funny, I was looking at it myself just today.

I was right, the problem is because every word is being transferred solely.
I think that means that when the sentence will be breaked into lines, they'll be in the wrong order as well.

That's why it's probably not enough to reorder the words in every line; we should reorder the whole splashed string. that makes me think, we can fix this one specific problem with a quickfix (you can check if you encounter a hebrew word by the return value of bidi_l2v), but that made me think, hebrew words are displayed backwards in the virtual keyboard screen for a similar reason: it writes every character to the screen alone, ignoring LTR languages ordering. to really fix that we have to make sure we put the pointer (marker) in the right place when writing or moving in between letters. and it will probably will be easier if we design the right functions for it. anyhow, I'm still thinking about it.

Loading...