Rockbox

Tasklist

FS#5821 - With fade on pause/stop enabled, UI doesn't update play/pause status indicator

Attached to Project: Rockbox
Opened by tim e (timecop) - Wednesday, 16 August 2006, 03:19 GMT
Last edited by Jonathan Gordon (jdgordon) - Sunday, 15 June 2008, 11:23 GMT
Task Type Feature Requests
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

So, when 'fade on pause/stop' option (on by default) is enabled in rockbox, the following occurs:

1) user listens to some music
2) user presses pause/stop while looking at screen
3) x number of seconds pass, while the user wonders why the hell the song hasnt paused
4) user keeps pressing pause trying to pause the song
5) input queue now has 4-5 pause presses, and song keeps fading in and out for 20+ seconds
6) user finally notices that 'play/pause' symbol in the titlebar changes, but only AFTER the song has been faded out and paused.
7) user is unhappy and deletes rockbox.

what should happen:
1) user listens to some music
2) user presses pause/stop while looking at screen
3) the gui immediately reflects the selected action (pause) by changing the play/pause symbol in titlebar
4) user is now happy, and waits for the song to fade out and pause/stop.
5) another satisfied customer!
This task depends upon

Closed by  Bj√∂rn Stenberg (zagor)
Sunday, 15 June 2008, 11:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  Closing all feature requests.
Comment by Mikael Magnusson (mikaelh) - Wednesday, 16 August 2006, 03:34 GMT
05:30:40 <safetydan> Paul_The_Nerd, so it's probably a feature request to
add another state to the WPS "pausing"

05:31:30 <Mikachu> i think pressing play while it is fading out should
inverse the fade instantly, not wait for the fadeout
05:31:41 <Mikachu> ideally, it's probably hard
Comment by Dan (Skyly) - Saturday, 04 November 2006, 13:02 GMT
Excellent idea though
Comment by Billy (ipodfoo) - Saturday, 16 December 2006, 18:33 GMT
I second that. I got fed up with the wps bitmap delay and have fade off now. Another cool thing would be to have a choice of fade times. I find the default too long. Just my 2p's worth.
Comment by Thias Hias (ThiasHias) - Tuesday, 13 February 2007, 11:30 GMT
I totally agree with this request.
I first thought, this was a bug and I thought the play/pause doesn't work sometimes... then I realized, it was the fade in and -out that caused the delay in icon-change. And it is annoying, somehow.
Comment by Alexander Thomas (DrLex) - Tuesday, 10 April 2007, 18:15 GMT
I also agree with this and I also vote for either a shorter default fadeout or a choice of fade times. When I pause a song, I mostly want it to stop pretty much immediately, not after 3 seconds.
Comment by Danilo (gwrtheyrn) - Thursday, 29 November 2007, 12:04 GMT
yeah, that's exactly what i experienced today. it would be nice if that would get fixed...
Comment by Marc Guay (Marc_Guay) - Friday, 28 March 2008, 22:30 GMT
The fade out time is more than reasonable on the e200; I have no problem with realizing that my keypress has been recoginized. Was the fade time changed at some point, and this can therefore be closed? Edit: The main problem still exists, the play-status not updating immediately.

Loading...