Rockbox

Tasklist

FS#5926 - First Up/Down is ignored when browsing radio stations

Attached to Project: Rockbox
Opened by Alexander Levin (fml2) - Friday, 01 September 2006, 19:39 GMT
Last edited by Rani Hod (RaeNye) - Wednesday, 20 September 2006, 13:25 GMT
Task Type Bugs
Category User Interface
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Model: iriver H120, Build: 2006-09-01 17:59, Default settings

Installed the build (settings were reset since the settings version was changed)
Changed file view to 'All'
Went to ./rockbox/fmpresets, chose a preset file -> radio is activated
Changed to preset mode
Pressed NAVI -> station list displays
* Pressed DOWN -> *** the cursor doesn't move ***
Pressed DOWN once more -> cursor moves
Left station list screen
Pressed NAVI -> station list displays
* Pressed UP -> *** the cursor doesn't move ***
Pressed UP once more -> cursor moves
This task depends upon

Closed by  Jonas Häggqvist (rasher)
Friday, 22 September 2006, 19:30 GMT
Reason for closing:  Fixed
Additional comments about closing:  By request of submitter.
Comment by Dominik Riebeling (bluebrother) - Friday, 01 September 2006, 19:42 GMT
Have you checked the "first keypress enables backlight only" setting? Works perfectly for me, maybe you have reloaded your old settings from a cfg file before (happens to me sometimes)?
Comment by Alexander Levin (fml2) - Saturday, 02 September 2006, 08:54 GMT
The settings were reset to their pristine state. At other places all key presses (also the first) were respected. But I'll try with a later build, naybe the problem will magically go away.
Comment by Rani Hod (RaeNye) - Sunday, 17 September 2006, 12:34 GMT
I tried to reproduce the problem but couldn't.
Please verify whether it persists.
Comment by Alexander Levin (fml2) - Tuesday, 19 September 2006, 18:28 GMT
Yes, the problem still persists with the build of 060919-1341
Comment by Rani Hod (RaeNye) - Wednesday, 20 September 2006, 13:24 GMT
Confirmed on X5 too.
Happens on preset or scan modes.
Happens whether radio screen is entered via a .fmr file or the main menu.
Comment by Alexander Levin (fml2) - Thursday, 21 September 2006, 09:04 GMT
Also, the first press of the stop button (H1xx) is ignored. So if you enter the FM preset list and want to leave it with 'Stop', you have to press Stop twice.
Comment by Steve Bavin (pondlife) - Thursday, 21 September 2006, 09:10 GMT
Again - check your configuration under General Settings > Display > LCD Settings > First Keypress Enables Backlight Only - set it to Off if it was On.

I see this was already suggested, but you never confirmed you checked it. It was enabled by default after clearing settings in older builds.
Comment by Dominik Riebeling (bluebrother) - Thursday, 21 September 2006, 09:19 GMT
I can confirm the keypress eating behaviour.
When opening the presets list from the FM screen, the first keypress in that list gets ignored regardless of the key itself. I guess this is caused by the fm screen not using the button actions but reading the buttons itself. I think converting the fm screen to the button actions would be the best solution. I already had a first attempt on this but currently I don't have time to work on it anymore and unfortunately I'm really new to the action stuff.

At least I can definitely say it's not caused by the "first keypress enables backlight first".
Comment by Alexander Levin (fml2) - Thursday, 21 September 2006, 13:14 GMT
I'm aware of the 'first keypress enables backlight first' option. It's not enabled. And if it were, the first key press would be ignored everywhere, e.g. also in the file browser. But that doesn't happen (and right so). But I see that other users (more competent than I) have also confirmed the bug.
Comment by Alexander Levin (fml2) - Friday, 22 September 2006, 19:28 GMT
I'd like to confirm that with the build from Sep 22 2006, 13:40, the bug doesn not occur anymore. Button action code has obviously had an effect! The bug can be closed IMHO. Thanks!

Loading...