Rockbox

Tasklist

FS#6021 - ipod video 30 gig dont charge

Attached to Project: Rockbox
Opened by Gary (MrRich489) - Monday, 18 September 2006, 13:03 GMT
Last edited by Rani Hod (RaeNye) - Tuesday, 19 September 2006, 15:44 GMT
Task Type Bugs
Category Battery/Charging
Status Closed
Assigned To No-one
Operating System All players
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

battery dont charge all they way or it dont charge at all or it charges and then dis chargeis the battery. u have 2 boot in 2 the ipod fire ware to charge
This task depends upon

Closed by  Nils Wallménius (nls)
Sunday, 04 February 2007, 21:55 GMT
Reason for closing:  Duplicate
Additional comments about closing:  This is a duplicate of  FS#5848 
Comment by Ralf Herz (herz42) - Tuesday, 19 September 2006, 06:34 GMT
At the moment, 'normal' charging while running the Rockbox firmware only works with 12V adapters, not over USB.
So you are right, the best way to charge over USB is to boot into the original firmware for that.

In Rockbox the current from USB is limited to 100mA, which could be just enough to slooowly charge, but as soon as the player does anything else than ideling (disk spinning or backlight on), the iPod battery is effectively discharging.


Comment by Gary (MrRich489) - Tuesday, 19 September 2006, 12:20 GMT
so what would be the best charger to get the mac one or a belkin one or i could make one but just by plugin 12v in to the ipod trew the cable
Comment by Ralf Herz (herz42) - Tuesday, 19 September 2006, 21:31 GMT
The firewire cable charger from apple should work. The (newer) USB cable charger not.

I have a Belkin car adapter (which also provides line-out audio) that plugs into a 12V cigarette lighter. That I have connected to a normal 12V wall wart. Works fine.

When you make your own cable/charger, use a firewire cable. Connecting 12V to an USB cable will almost surely kill your iPod USB port.

Loading...