Rockbox

Tasklist

FS#6063 - Cannot change default recording directory.

Attached to Project: Rockbox
Opened by Davide (Davide-NYC) - Monday, 25 September 2006, 14:55 GMT
Task Type Bugs
Category Recording
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This bug exists for the iRiver H120 build and the H120 sim.

I just performed a fresh CVS checkout. Built and installed on H140 target (version 060925-0356)
GoTo: - menu -> recording -> recording settings -> directory
Select either the '/recordings' item or the 'Current Directory' item then I pressed every button (long and short press)

None of them take me to the virtual keyboard or a file browser or anything. (I'm not familiar with how it's supposed to work so I do not know what to expect)
All I can do is cancel, which takes me up a menu level, [Stop long, Stop short, Left long, Left short] or simply go up a menu level [Right long, Right short, Navi short].

This is probably a very easy fix and maybe caused by the recent button code revision.(?)
This task depends upon

Closed by  Dominik Riebeling (bluebrother)
Monday, 25 September 2006, 17:14 GMT
Reason for closing:  Invalid
Additional comments about closing:  closed upon request as it appeared not to be a bug.
Comment by Dominik Riebeling (bluebrother) - Monday, 25 September 2006, 15:02 GMT
"Current directory" is the directory the file browser was last when entering the main menu. I just tried this on h120:
- change to some folder
- go to the main menu, recording settings
- set "Directory" to "current"
- go to the recording screen
- record.
- quit from the recording screen and verified the generated files are in the folder I had the browser left.

Works nice for me. AFAIK there is no possibility to (fixed) set an arbitrary directory, "current" always applies to the last folder the browser was showing.

Could you please verify this works for you?
Comment by Davide (Davide-NYC) - Monday, 25 September 2006, 16:38 GMT
False alarm. Please close this Bug Report.
I have posted a feature request in the forum http://forums.rockbox.org/index.php?topic=6649.msg51967#msg51967 and on flyspray http://www.rockbox.org/tracker/task/6064

Loading...