Rockbox

Tasklist

FS#6085 - AJBR A-B repeat loop inoperable

Attached to Project: Rockbox
Opened by Jeff Burden (JazzMan) - Thursday, 28 September 2006, 17:09 GMT
Last edited by Daniel Stenberg (bagder) - Wednesday, 03 January 2007, 10:11 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Archos Recorder
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have a Archos Jukebox Recorder 15. I am using the daily build for 9-28-06. The menu selection that changes the repeat function to A-B repeat is selectable. But when it is selected the unit does not place the markers intended for the repeated area and therefore you can't define the section to repeat. On Left and On Right are supposed to drop the markers but nothing happens.
This task depends upon

Closed by  Steve Bavin (pondlife)
Thursday, 04 January 2007, 08:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  As reported by the original reporter.
Comment by Lenny Koepsell (lenny) - Thursday, 28 September 2006, 23:16 GMT
I experienced a similar problem on my H140 yesterday.

On the H140, to set a marker one needs to press ON+LEFT/RIGHT. The problem is, the marker only registers if this combo is almost instantaneous. One cannot hold down ON 5 seconds before pressing LEFT; one must make the time between the two buttons very short to get the marker to register. This is workable but not ideal. IMHO it would be better if one could hold the ON button an indefinate amount of time before pressing LEFT/RIGHT and still have the marker register. I almost submitted a feature request for this.

I hope we are talking about the same issue. I don't know if the behavior was like this before the buttonaction code.

Also, here's a somewhat releated (A-B repeat) problem I opened yesterday: #6078
Comment by Jeff Burden (JazzMan) - Friday, 29 September 2006, 17:00 GMT
The Archos uses the same ON+LEFT/RIGHT key combination to drop the marker. I tried as you suggest, hitting both keys simultaneously, but this still doesn't drop the marker on the Archos. The behavior originally was as you submit "hold the ON button an indefinate amount of time before pressing LEFT/RIGHT and still have the marker register." I'm also having trouble accessing my pitch control with the daily builds. I can backrev my unit to Ver 2.5 and everything works beautifully.
Comment by Dan (Skyly) - Saturday, 04 November 2006, 12:23 GMT
I agree, I have this problem on my H340. Its next to impossible to use A-B repeat.But I would rather see this method of A-B repeating be ditched completely.

Using three buttons that require holding can be too impractical for people trying to time their repeat points accurately.

The feature is entirely a tap-one-button task in the first place; it works perfectly without requiring extra controls.
The H340 actually has a button deliberately labelled 'A-B' for this feature, so the 3-buttons method looks bizarrely inaccessible.

I don't know about the Archos, but on the H340, tap-record and hold-record are completely unused in this situation, so there are controls to spare. Even if there weren't, I think something other than repeat A-B should be given the 3-buttons controls. As it is, A-B repeat could easily be put back on the A-B button if the current A-B functionality was simply moved over to the wasted record button.
Comment by Jonathan Gordon (jdgordon) - Monday, 25 December 2006, 12:54 GMT
Is this bug still valid?
I added code last week which allows targets to use a 1 button setup for a-b mode, but it isnt perfect so targets (like the 3 mentioned) which have the extra butttons shhuold use them instead of a single button.
Comment by Jeff Burden (JazzMan) - Wednesday, 27 December 2006, 16:33 GMT
What is the new method(if any) to access A-B functions on the Archos Recorder?. I put the new code on it, but I don't know which keys are supposed to activate it now that old key combo doesn't work. I activate A-B mode but can't get markers to drop and therefore, no looping happens.
The Wiki still says that the following is the proceedure...
A-B.
Repeats between two user defined points within a track, typically used by musicians when attempting to learn a piece of music. This option is more complicated to use than the others as the player must first be placed into A-B repeat mode and then the start and end points defined.
Hold Play and press Left — Sets Start Point (A)
Hold Play and press Right — Sets End Point (B)
Comment by Jonathan Gordon (jdgordon) - Thursday, 28 December 2006, 00:43 GMT
hmm.. ok, just realised that the key combinations are not set at all for the recorder. I'll fix that later today
Comment by Jeff Burden (JazzMan) - Wednesday, 03 January 2007, 20:20 GMT
Sorry, but shortly after I requested this task be reopened I realized that I had made a dumb mistake testing the feature.
And I didn't know how to cancel the request. Turns out that it works fine. Good job Jon! Thanks a lot!

Loading...