Rockbox

Tasklist

FS#6198 - Tag Cache Not Ready

Attached to Project: Rockbox
Opened by Ryan (Ryno) - Monday, 16 October 2006, 22:57 GMT
Last edited by Steve Bavin (pondlife) - Tuesday, 31 July 2007, 08:18 GMT
Task Type Bugs
Category ID3 / meta data
Status Closed
Assigned To No-one
Operating System iPod 5G
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm having some problems with the Tag Cache on my iPod 5g 30Gb.

I had the rockbox installed before and it worked fine... I recently did a full restore of my iPod and copied all my music back on with iTunes. Now, when I click "Initialize Tag Cache" it works for a while... and seems to finish... so I restart. But it gives me the "Tag Cache Not Ready" error when trying to read it.

Any ideas?
This task depends upon

Closed by  Steve Bavin (pondlife)
Tuesday, 31 July 2007, 08:18 GMT
Reason for closing:  Invalid
Additional comments about closing:  Support should not be in the tracker.
Comment by Dominik Riebeling (bluebrother) - Tuesday, 17 October 2006, 06:50 GMT
Please note that this is a tracker, not a support channel. Use the forums, mailing lists or IRC for problems like this first -- I'm pretty sure the "bug" you filed is not a bug. Sorting out real bugs takes quite an amount of time from devs that would better spent coding.
Remove all tagcache files from the .rockbox folder (*.tcd) and try again. Make sure there aren't any temporary tagcache files left.
Comment by Ryan (Ryno) - Tuesday, 17 October 2006, 10:25 GMT
I've reinstalled the rockbox and reinitialized the tag cache several times now... with the same result

I also just tried updating about 500 songs at a time... and it worked untill about 3/4s way through.
Comment by Dominik Riebeling (bluebrother) - Tuesday, 17 October 2006, 10:56 GMT
have you cleared your settings before reinitializing tagcache and manually removed the tagcache files as I asked you before?
Comment by Ryan (Ryno) - Tuesday, 17 October 2006, 17:35 GMT
yes... I've tried that a few times to make sure
Comment by Dominik Riebeling (bluebrother) - Tuesday, 17 October 2006, 17:49 GMT
please try going back to your previous build and see if it still happens. Also, looking into the tagcache info screen below the debug menu may help finding the cause.
Comment by Ryan (Ryno) - Tuesday, 17 October 2006, 18:16 GMT
...sorry, what do you mean by "build"?
I've re-installed the latest version of Rockbox a couple times. Do you want me to try an older build of the Rockbox?
Comment by Ryan (Ryno) - Tuesday, 17 October 2006, 18:16 GMT
oh... and where is this "debug menu"?

Thanks alot 'eh?
Comment by Dominik Riebeling (bluebrother) - Tuesday, 17 October 2006, 18:41 GMT
I mean an older version, specifically that version you were using before updating. You can find older builds on the daily builds page.
The debug menu can get accessed via the "Info" entry in the main menu. It has a "view Tagcache info" entry that shows some information about Tagcache.
Comment by Ryan (Ryno) - Tuesday, 17 October 2006, 18:59 GMT
How wierd... I do not have that menu option "view Tagcache info"... is this hidden if Tag Cache is not initialized?

I will try an older version...
thanks
Comment by Ryan (Ryno) - Tuesday, 17 October 2006, 18:59 GMT
sorry... I see the tagcache info thing now... my bad
Comment by Ryan (Ryno) - Wednesday, 18 October 2006, 04:28 GMT
Yay... rolled back to 2006-09-20 and it initialized as it should... thanks...

buuuut there is still some change between builds 2006-09-20 and 2006-10-12 that is causing the problem. Is there anything I can do to try to fix it?

thanks again... hope we can get this bug fixed.
Comment by Dominik Riebeling (bluebrother) - Wednesday, 18 October 2006, 06:24 GMT
you haven't telled what file types are you using. There have been some changes recently to the aac codec to make it faster but also a bit pickier about the files. It would be great if you could try the older builds successively until you find the one that isn't working anymore.
Comment by Gemini Apollo (golemB) - Monday, 06 November 2006, 08:15 GMT
I also have problems on my iAudio X5 (60gb), using Rockbox version 061029-0124. I am using the tagnavi_custom.config made by Roolku (at http://forums.rockbox.org/index.php?topic=6661.msg55587#msg55587), since the default view reported "Tagcache is not ready".

I reset my settings, deleted the tagcache file, told it to reinitialize, and waited several minutes. Debug | Tagcache Info reports:
"Initialized: Yes", but everything else is 0 or No.

I use OGGs and MP3s; I also have a number of video files (none actually playable on my Rockbox iAudio) in the Video directory. There are a few JPG album art covers in the music folders, as an artifact from my computer's structure. I also have a separate directory for random data files (transporting between computers). I probably have 7,000-8,000 files total, the vast majority of which are music files.
Comment by Gemini Apollo (golemB) - Monday, 06 November 2006, 08:37 GMT
BTW, the system always creates a 719KB file called /.rockbox/tagcache_tmp.tcd. If I open it in VIm, it seems to contain a bunch of artist or album names, along with special characters (I didn't try a hex editor, and I didn't make any changes of course). When I boot Rockbox, it says "Committing tagcache [1/7]," then "Loading", then plays from where the bookmark left off. Still the same problems as above.
Comment by Dominik Riebeling (bluebrother) - Friday, 06 July 2007, 22:47 GMT
is this still a problem with current builds?
Comment by Gemini Apollo (golemB) - Saturday, 07 July 2007, 03:30 GMT
My iAudio X5 died a few months ago (too many drops onto the sidewalk), so I can't test. :-( I should have a new Cowon F2 next week, but that's a whole 'nother device and rather different.

Loading...