Rockbox

Tasklist

FS#6267 - Simulator does not maintain pause status properly

Attached to Project: Rockbox
Opened by Steve Bavin (pondlife) - Tuesday, 31 October 2006, 17:30 GMT
Last edited by Steve Bavin (pondlife) - Saturday, 09 February 2008, 15:00 GMT
Task Type Bugs
Category Simulator
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In the SDL simulator, pause playback, then press left once to skip to the start of the current track. Playback resumes, although the status is still displayed as paused.

This is caused by the SDL implementation of pcm_play_stop() - it always clears the PCM pause status, unlike on real SWCODEC devices.
This task depends upon

Closed by  Steve Bavin (pondlife)
Saturday, 09 February 2008, 15:00 GMT
Reason for closing:  Fixed
Additional comments about closing:  Works perfectly now.
Comment by Steve Bavin (pondlife) - Monday, 30 July 2007, 21:52 GMT
The same problem occurs if I rewind or fast-forward, FWIW.

Loading...