Rockbox

Tasklist

FS#6279 - no gap between tracks (gapless playing concerts etc.)

Attached to Project: Rockbox
Opened by Grzegorz (natror) - Friday, 03 November 2006, 07:59 GMT
Task Type Feature Requests
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Dear Developers,
The reason I try RockBox is I look for an iPod software
that would play operas with no gaps between tracks.

So far (CVS-061031) Rockbox does make such gaps.

Please, add an option that would buffer the beginning of the next track
so it could play as one sound stream.

Other classical music lovers also expect that feature.
(And non-classical maybe too: for the live (concert) recordings).

But, in general, RockBox is great!!!
Best regards,
Natror (Grzegorz Murzynowski)
This task depends upon

Closed by  Björn Stenberg (zagor)
Friday, 03 November 2006, 08:09 GMT
Reason for closing:  Invalid
Additional comments about closing:  Closing all feature requests.
Comment by Nils Wallménius (nls) - Friday, 03 November 2006, 08:07 GMT
Rockbox _does_ play gaplessly and it's not an option.
Howerver certain formats (like mp3) require special
encoding settings to work truly gaplessly, please see
the following wiki page for further instruction and
report back if the problem persists.

http://www.rockbox.org/twiki/bin/view/Main/GaplessHowTo
Comment by Linus Nielsen Feltzing (linusnielsen) - Friday, 03 November 2006, 08:08 GMT
Of course Rockbox buffers the beginning of the next track. How could we call it gapless if it didn't? The problem is that MP3 files must be encoded in a way that makes this possible to play gaplessly. It isn't enough to simply concatenate the files.

Rockbox does every attempt to ensure gapless playback, but there can still be gaps if the file isn't encoded properly (with LAME), or if it has tags that Rockbox can't understand.

Loading...