Rockbox

Tasklist

FS#6326 - Gapless is borked, has artifact at track tranistion

Attached to Project: Rockbox
Opened by Joaquim Dias (dunno) - Monday, 13 November 2006, 17:54 GMT
Last edited by Steve Bavin (pondlife) - Tuesday, 31 July 2007, 10:45 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Recently with most recent build and going back several builds I have noticed that there is a slight "bump" or artifact between track transitions with gapless albums/music.

H140
LAME 3.90.3 --alt-preset standard

Replay Gain enabled
eq enabled

Crossfade DISABLED
Auto Change Directory DISABLED
All Voice DISABLED
This task depends upon

Closed by  Steve Bavin (pondlife)
Tuesday, 31 July 2007, 10:45 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  No new input for 9 months. Reopen if it's really a problem.
Comment by Joaquim Dias (dunno) - Monday, 13 November 2006, 18:20 GMT
footnote:

Let the player go through the whole album as it doesn't do it with all track transitions.

Comment by Steve Bavin (pondlife) - Monday, 13 November 2006, 19:35 GMT
Hi Joaquim,

If you get a chance, can you work backwards (or binary chop) and work out which date this problem started? I'll look into if I have time, but this would be useful info.
Comment by Mark Arigo (lowlight) - Monday, 13 November 2006, 21:20 GMT
How are your mp3's tagged? Some programs default to adding ID3 and APE tags to mp3's (for example, older version of foobar2000, mp3tag might add both, mp3gain uses APE tags, etc.). Due to the way gapless is handled in Rockbox, the presence of APE tags at the end of mp3's will break gapless playback in cases where more than one frame needs to be trimmed.

I plan to commit a patch to strip APE tags very soon (today or tomorrow).

If you are sure your files don't have APE tags, then I'm not sure what would have changed to break gapless playback.
Comment by Joaquim Dias (dunno) - Monday, 13 November 2006, 21:30 GMT
I only have ID3 V2 and V1 tags no ape tags, and player is set to V2 first then V1
Comment by Joaquim Dias (dunno) - Monday, 13 November 2006, 21:33 GMT
perhaps I can send a sample of the offending tracks to someone ?
Comment by Joaquim Dias (dunno) - Monday, 13 November 2006, 22:01 GMT
Hmmm, I'll be listening to a gapless album and it'll go "bump" at a track transition, I make a mental note, but trying to reproduce it at will now is proving difficult, don't know what to say, sorry to hassle you guys, I'll try to narrow it down a bit more, i.e. if the HD spins at track transition.

Many Thanks
Comment by Steve Bavin (pondlife) - Tuesday, 14 November 2006, 08:40 GMT
There is definitely a timing problem in playback when entries in the track structure are re-used. Normally this will only happen after 32 tracks have played, so it's not very noticable. If you can make your own build, edit playback.h to change:
#define MAX_TRACK 32
to
#define MAX_TRACK 3
Doing this makea any problems in this area much more reproducible.
Might be unrelated, but might also help.
Comment by Dominik Riebeling (bluebrother) - Tuesday, 14 November 2006, 19:32 GMT
from reading the GaplessHowTo wiki page I believe you need to add the --nogap switch when encoding. Have you also tried formats that can do gapless natively (like ogg)? I haven't found gapless to be broken on my player (mostly oggs, and I don't expect mp3 to be completely gapless due to its technical reasons ...)
(Side note: *if* the behaviour of lame has changed so that --nogap isn't needed anymore it would be good if someone could adjust the wiki page accordingly, optimally also telling which versions need the flag.)
Comment by Thom Johansen (preglow) - Tuesday, 14 November 2006, 19:53 GMT
--nogap is only needed on HWCODEC platforms. I believe this is stated on the wiki page, but could probably be stated more clearly. No flag is needed when encoding gapless with all recent versions of LAME.
Comment by Joaquim Dias (dunno) - Tuesday, 14 November 2006, 20:46 GMT
Thanks for the comments.

ALL my 120gigs of music is encoded to uberstandard (without -no gap), which reccommends LAME V3.90.3 --a-p s, this version of LAME was the reccommended version by the authors of LAME until recently, V3.90.3 has been superceded by .97 or suchlikes. The reason that I mention this is that I have gotten rid of my CD's as I ripped then all to mp3, so I don't have the luxury of ripping to ogg or suchlikes, even if I did have the originals I doubt I would spend the time/energy re-ripping my whole collection...bottom line...., i'm stuck with good quality/transparent mp3.

Many thanks for all your inputs.

Loading...