Rockbox

Tasklist

FS#6363 - Wrong WPS after skip back at the end of a song

Attached to Project: Rockbox
Opened by Alexander Levin (fml2) - Monday, 20 November 2006, 20:59 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The bug can be reproduced with the build CVS-061118 and a MP3 file with 128kbps and 44100 Hz (created with LAME encoder through CDEx GUI).
Device: Iriver H120.

How to reproduce:

1. Start a song (song A). I used a song of about 3 min length.
2. Wait until it's come to about 10 secs before the end. You can also use fast forward button to faster get to this point.
3. Wait until it gets to 2 or 1 or 0 secs before the end (I use the remaining duration in WPS). WIth 3 secs before the end, the error does not occur.
4. Press left. This should start the song A from the beginning since it's still displayed in the WPS.

However, the next song (song B) starts. If the remaining time was 2 secs it goes down to 0. But the WPS still displays the song A. Progress bar and time in the WPS are frozen at the end of the song A (e.g. remaining duration is 0:00). After pressing NAVI (which displays the file browser), the cursor is on the song A. Pressing PLAY (cursor has not been moved) gets back to WPS. There, the song B with correct progress bar and time indicators is displayed.

Here is also the configuration file (exported just before submitting this bug report) -- in order to avoid many questions about the settings.
This task depends upon

Closed by  Steve Bavin (pondlife)
Tuesday, 21 November 2006, 07:20 GMT
Reason for closing:  Duplicate
Additional comments about closing:  See  FS#2687 .

Loading...