Rockbox

Tasklist

FS#6364 - Loading a bookmark during playback fails

Attached to Project: Rockbox
Opened by Stephane Doyon (sdoyon) - Tuesday, 21 November 2006, 15:11 GMT
Last edited by Steve Bavin (pondlife) - Friday, 07 March 2008, 08:45 GMT
Task Type Bugs
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Loading a bookmark while music is already playing (through the onplay
menu) doesn't work: playback just stops.

I've traced it a bit and confirmed that bookmark_play() calls
playlist_start(), which has to call audio_play().

I've found that adding audio_stop() at the top of bookmark_play() solves
the problem and makes it work. But that's probably not the correct fix,
is it?
This task depends upon

Closed by  Steve Bavin (pondlife)
Friday, 07 March 2008, 08:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  Should be fine as of r16518. Let us know if not.
Comment by Nicolas Pennequin (nicolas_p) - Thursday, 14 December 2006, 03:27 GMT
It seems there is something wrong in the codec loading because the code which is used when the playlist is finished playing is called in this case right after the bookmark is loaded... This makes the playback stop when it shouldn't.
All that has to be done is comment out one line, but it's not a good fix because it prevents the WPS from disappearing when the end of the playlist is reached, and possibly other negative effects... Anyway, with this bookmarks work.
Comment by Tom Ross (midgey34) - Friday, 03 August 2007, 05:19 GMT
Bug is still present in SVN (r14152).
Comment by Marc Guay (Marc_Guay) - Thursday, 06 March 2008, 18:59 GMT
Cannot reproduce with Sansa e200 + r16523.

Loading...