Rockbox

Tasklist

FS#6369 - screen corruption and hang using very long tags

Attached to Project: Rockbox
Opened by Tim Pickersgill (tpickers66) - Tuesday, 21 November 2006, 21:38 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System Iriver H100 series
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Playing a file with a very long title (183 chars: "Nine Feet Underground (Nigel Blows a Tune - Love's a Friend - Make It 76 - Dances of the Seven Paper Hankies - Hold Grandad by the Nose - Honest I Did! - Dissassociation - 100% Proof)") the screen corrupts and scrolls for a bit (see attached captures) and then rockbox hangs. I have to use the reset button on my H140 to get it back. I have had to reduce the tag length to allow it to play.

The filename is also very long (158 chars: "05 - Nine Feet Underground (Nigel Blows a Tune - Love's a Friend - Make It 76 - Dances of the Seven Paper Hankies - Hold Grandad by the Nose - Honest I Di.mp3") but I have left this as-is and it plays fine.
This task depends upon

Closed by  Peter D'Hoye (petur)
Saturday, 03 March 2007, 14:57 GMT
Reason for closing:  Fixed
Comment by Peter D'Hoye (petur) - Tuesday, 12 December 2006, 11:08 GMT
can you try the patch attached to the related task?
Comment by Peter D'Hoye (petur) - Tuesday, 12 December 2006, 22:23 GMT
nevermind, that patch won't change a thing :/
Comment by Peter D'Hoye (petur) - Wednesday, 28 February 2007, 21:01 GMT
Seeing that the related bugreport got closed (fixed) I assume this one is to be closed too?
Tim Pickersgill, can you confirm the issue is fixed?
Comment by Tim Pickersgill (tpickers66) - Saturday, 03 March 2007, 14:28 GMT
tested yesterday with the latest SVN build. This is working now and displays the long tag correctly. The display is correct for the current track and the next track WPS tags and rockbox doesn't hang.

Loading...