Rockbox

Tasklist

FS#6378 - WPS lockup with id3 tag > 128 characters

Attached to Project: Rockbox
Opened by Wesley (Yotto) - Thursday, 23 November 2006, 07:23 GMT
Task Type Bugs
Category Themes
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When a dynamically created line (Say, %ia) has over 128 characters, the WPS screen freezes, playback stops, and you must do a hard reset. This happens consistently on my iPod video 30gig, but I assume it would happen on other models.
I could (and do) just edit the tags, but as this happens on some podcasts, it is a constant issue.
This task depends upon

Closed by  Magnus Holmgren (learman)
Sunday, 17 December 2006, 15:52 GMT
Reason for closing:  Fixed
Comment by Peter D'Hoye (petur) - Monday, 11 December 2006, 22:16 GMT
Can you build your own version? And try the attached patch?
Comment by Peter D'Hoye (petur) - Monday, 11 December 2006, 22:23 GMT
hmmm I'm unable to reproduce using a very long artist name using iCatcher. It does use %ia....
Comment by Wesley (Yotto) - Monday, 11 December 2006, 22:44 GMT
Sorry, I left out one very important part. %s has to be on the line as well to make it scroll. I just tested it again and it locked up.

I sadly do not know how to compile.
Comment by Peter D'Hoye (petur) - Tuesday, 12 December 2006, 21:35 GMT
I tried with iCatcher and it doesn't want to crash. What wps do you use?
Comment by Peter D'Hoye (petur) - Tuesday, 12 December 2006, 22:23 GMT
Sorry, that attached patch won't change a thing
Comment by Robert Kukla (roolku) - Friday, 15 December 2006, 18:13 GMT
Hm, I just run into this myself and trying to reproduce it I noticed that it doesn't crash if the tags are in unicode (as saved by winamp). The same track and only the tag changed to ISO 8859-1 (in tag&rename) crashes rockbox. I will try and do some more investigation with logf later tonight, but maybe this fact gives someone an idea on what goes wrong here - in theory the actual id3->title string should be the same after unicode_munge() in id3.c...

Loading...