Rockbox

Tasklist

FS#6387 - Get rid of SYSFONT_PITCH_xxx strings

Attached to Project: Rockbox
Opened by Alexander Levin (fml2) - Monday, 27 November 2006, 21:25 GMT
Last edited by Nils Wallménius (nls) - Sunday, 05 August 2007, 19:23 GMT
Task Type Patches
Category Language
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I saw the discussion in IRC. As I'm the last person who touched the pitch screen code...

Also changed the intial pitch screen mode to be 'semitone' (it was 'percent' before)
Closed by  Nils Wallménius (nls)
Sunday, 05 August 2007, 19:23 GMT
Reason for closing:  Accepted
Comment by Peter D'Hoye (petur) - Friday, 01 December 2006, 08:25 GMT
Alexander, the reason I didn't commit this one last night is because I'm not 100% convinced that duplicating strings to rename them is the way to go. As the issue isn't very critical I think it may be better to do a major lang file cleanup. And maybe first get rid of all sysfont stuff everywhere. This means a bit of work in recording screen,...
Comment by Alexander Levin (fml2) - Friday, 01 December 2006, 11:56 GMT
D'accord. This should be discussed with someone who's more familiar with the lang file logic and can better estimate the implications.

BTW: some string IDs (e.g. PITCH) were present since long ago, I just introduced those missing.

Thank you very much Peter!

Loading...