Rockbox

Tasklist

FS#6390 - Rumbling noise in the main FM window

Attached to Project: Rockbox
Opened by Stephan (SteveMC) - Tuesday, 28 November 2006, 13:40 GMT
Last edited by Steve Bavin (pondlife) - Thursday, 17 July 2008, 10:01 GMT
Task Type Bugs
Category FM Tuner
Status Closed
Assigned To No-one
Operating System iAudio X5
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I'm using an X5 60GB daily build 27/11. Although radio sound is far better than with original firmware (improved high frequency response) there is a problem with a rumbling noise that appears when the radio is on the main window. It's very noticeable and obvious and the noise remains if you mute the sound (push play). Fortunately it dissapears when moving to the recording menu (the noise is not recorded) or simply moving to the preset list. This was a real issue with the original firmware: the same noise also appeared but only WHEN recording mode was activated, so the noise was recorded! On the contrary, there was no noise when listening to the radio without recording. Though i prefer this minor issue, maybe something could be done about it.
Another thing is that the sound cannot be adjusted in radio mode (EQ doesn't work though it appears in the radio settings).
For the rest, you are doing a fantastic job turning a good machine into a near professional recording gear. WAV and AIFF recording is killer along with manual independent level adjustment with Peak detector and VU. Same for parametric EQ or dithering.

Just keep on rockin'! :-)
This task depends upon

Closed by  Steve Bavin (pondlife)
Thursday, 17 July 2008, 10:01 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Closure requested... closure performed!
Comment by Michael Sevakis (MikeS) - Tuesday, 28 November 2006, 18:11 GMT
"...there is a problem with a rumbling noise that appears when the radio is on the main window..."
I have never heard this. If I leave my recording gain at 0db and switch back and forth to and from recording, leave/enter the radio screen, it sounds the same. My headphones could definitely pick up stuff at any frequency. What FM region do you use? Mine is US/Canada.

If you are listening to it with the remote, you'll get interference for sure.

"Another thing is that the sound cannot be adjusted in radio mode..."
I don't believe the OF allows this either. The radio is currently run in analog bypass mode so you listen to the signal amplifed directly out of the radio chip. Radio could in principle be digitized, run through the DSP and then sent back out but would be more battery hungry. All the audio effects are software. The sound chip has no functionality of this sort (the iRivers' sound chip does and radio Bass/Treble can be adjusted). Applying DSP effects in radio mode would definitely need to be optional on that account.

BTW: Glad you think the recent addition of AIFF recording is worthwhile. :)
Comment by Stephan (SteveMC) - Wednesday, 29 November 2006, 09:18 GMT
Thx for fast reply,

I don't use remote, I use UE-10 earphones. Did you mute the sound in the main window? Is it perfectly quiet?
Maybe my earphones are too sensitive. Ok for sound adjust in radio mode. I noticed it wasn't connected to software as the oscilloscope and the VU-meter apps don't work with the radio. Still i don't understand why your radio sound is (much) better than with OF!

;-)
Comment by Michael Sevakis (MikeS) - Wednesday, 29 November 2006, 15:43 GMT
I did mute the sound and can hear now (forgot to mute :P) what you're saying really obvious on quiet stations (weak, talk, classical) as well. It is interference from the digital circuitry. If you increase the volume when muted it gets louder (the audio chip is not muted). Moving the cusor around in the menus and such also makes a noise. I suppose the screen could be frozen and tweaked to do less when in it and that would reduce internal data traffic.
Comment by Stephan (SteveMC) - Friday, 01 December 2006, 10:29 GMT
i'm glad to hear that this is not a problem with my X5 only.

My measures of the output noise gave the following results (+4dBu):

FM (mute) Main window: -75.99dB (RMS Unweighted)
FM (mute) Preset List Window: -87.48dB (RMS Unw.)
FM (empty carrier) Main window: -68.80dB (RMS Unw.)
FM (empty carrier) Preset list: -79.01dB (RMS Unw.)

In the Music mode (Stop mode): -105.2dB (RMS Unw.)

As you may see, there is more than 10 dB increase of noise level between both windows.

Also, There's no explanation of the Autoscan function (great feature but sensitivity is set too high, i get more than 65 stations (!) found but only 25 are well tuned).
Comment by Michael Sevakis (MikeS) - Friday, 01 December 2006, 15:26 GMT
I too have trouble with audio scanning finding weak stations and in addition totally missing strong ones that any other radio in the house would pick up (major local stations!). Should check if OF has similar behavior or not.
Comment by Michael Sevakis (MikeS) - Friday, 01 December 2006, 19:37 GMT
Got scanning and tuning working correctly now. Reception doesn't change when moving the unit around and all correct stations are found when scanning. A sensitivity option and minimizing data traffic in the screen may be in order.
Comment by Michael Sevakis (MikeS) - Sunday, 03 December 2006, 17:52 GMT
Will have a patch for a quieter screen (minimal activity), better reception (by far for x5) and better scanning (better than OF) ready soon. I hope it's good for all FM bands since it took me awhile to get it right over here. The TEA5767 doesn't like being rushed; it needs it sweet time to detect a signal and the algorithm must be right though not nescessarily exactly what the application notes say. The only reason I still need to have a timeout in the screen is to support that Stereo/Mono indicator. x5 also makes a lot of noise when switching to CPU idle mode and may refrain from doing so there.
Comment by Michael Sevakis (MikeS) - Monday, 04 December 2006, 00:20 GMT
argh, my x5's right button contact just went south and is almost perpetually pressed. :( can't keep testing well. thankfully it's just inside the end of the warranty period. the player's been treated very well and it seems like the buttons are just crappy. the rec button is fishy too. hope they're fast on repairs.
Comment by Stephan (SteveMC) - Monday, 04 December 2006, 08:30 GMT
Haha! read all your comments today. So you tested so much you broke your machine!
Thanks again for caring, i'll download the update. I think there's no autopreset in OF. I thought it was the mono/stereo indicator that was responsible for the traffic as it's updated almost instantly. Maybe it would be sufficient to show its state only when tuning in. No one cares if its mono or stereo as you can hear it anyway.
It's great to have unlimited number of preset and the ability to input long preset names.
Nice day to you.
Comment by Stephan (SteveMC) - Wednesday, 06 December 2006, 09:52 GMT
Hi!

In my opinion, the radio sound is more stable but the noise has increased!

Again, the noise measures (+4dBu):

Version 05-12:

FM (mute) Main window: -76.01dB (RMS Unweighted)
FM (mute) Preset List Window: -82.7dB (RMS Unw.)
FM (empty carrier) Main window: -65.7dB (RMS Unw.)
FM (empty carrier) Preset list: -68.9dB (RMS Unw.)

If you compare with last week's results, you can see that the signal-to-noise ratio has decreased, especially in the preset list window where, until now, it was almost quiet.

For your information, here are two little files recorded from LINE OUT which outputs the same background noise as the headphone connector.

- First one is FM with sound output muted version 27-12.

- Second one is the same with version 05-12.

Every 5 seconds the display was toggled from the Main FM window to the preset list screen, starting from the Main FM window.
Both were processed through a compressor to make it more obvious (but this is about how i perceive it through the earphones...!).

In the Preset List window, I can now hear a buzzing noise that is absent from V.27-12 (compare both files). clicks become more frequent as well.
If there's nothing to do about it, maybe you should revert to the old settings. It was not so bad, after all... ;-), and much better than OF, for sure.

I think the problem comes from the hardware. The analogue radio parts are too close to the digital circuitry and there must be a lack of insulation. I also noticed that the radio noise increases during recording due to the hd high frequency signals scrambling radio reception. Maybe new models come with DAB, who knows?
Comment by Michael Sevakis (MikeS) - Wednesday, 06 December 2006, 10:40 GMT
I haven't actually committed any of my changes yet! =) hehe

After scanning is near perfect and my x5 is back from repairs so I can continue to develop it, the radio screen will be tons quieter and the scanning solid. One big source of noise for the x5 is putting the CPU in idle mode. I may skip doing that for that reason on x5 only.
Comment by Stephan (SteveMC) - Thursday, 07 December 2006, 11:33 GMT
Lol Lol Lol! :-)...But the noise in the preset list window is real! i made a-b comparisons between these daily builds several times and the recordings and measures showed consistently the same results. Something must be different. I can't wait for real changes now... Hope you get your X5 back pretty soon!
Comment by Michael Sevakis (MikeS) - Thursday, 07 December 2006, 20:06 GMT
I'm mostly concerned about the noise in the radio screen and in general browsing. Once any major activity is going (lots of kepresses, using a plugin, recording screen, etc.), you will have noise...period :\\. I may experiment with slowing down the I2C drivers under certain conditions and see if that helps too since that polling for Stereo/Mono status is still being done every second. I don't think it always requires full speed esp. not to read/write 5 bytes to the radio chip. Sending my x5 back to Cowon for service was like parting with a loved one, only worse! :D

I can promise at least this: You will have rock solid tuning and station scanning and a much quieter radio screen (without freezing it) after I update.

Comment by Stephan (SteveMC) - Monday, 15 January 2007, 09:38 GMT
Hi Michael!

Did you get your X5 back?

:-)

Loading...