Rockbox

Tasklist

FS#6426 - iPod buffer and rebuffer without need

Attached to Project: Rockbox
Opened by Paulo H Kikunaga (PauloHK) - Monday, 11 December 2006, 20:10 GMT
Last edited by Peter D'Hoye (petur) - Wednesday, 13 December 2006, 21:38 GMT
Task Type Feature Requests
Category Music playback
Status Closed
Assigned To No-one
Operating System All players
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

I really don`t understand. I just put one single song to play, in loop. No others songs in current playlist, just one, with repeat all or repeat one mode.
So I go in debug > audio thread to see the buffer info. The song was filled in buffer by 5 times, and after played this 5 times, the HD spined and filled up the buffer again... Why this? Is the same song?
In Apple`s firmware this don`t happens. You play one song infinitely and the HD has no need to fill the buffer again.
My iPod is a video 5G 60gb.
This task depends upon

Closed by  Björn Stenberg (zagor)

Reason for closing:  Fixed
Additional comments about closing:  Closing all feature requests.
Comment by Václav Brožík (pabouk) - Wednesday, 13 December 2006, 20:46 GMT
The same problem was confirmed on iriver H120 and H340. See http://forums.rockbox.org/index.php?topic=7638.0
Comment by Peter D'Hoye (petur) - Wednesday, 13 December 2006, 21:38 GMT
This is current design. I've changed this entry into a feature request.
Comment by Václav Brožík (pabouk) - Thursday, 02 August 2007, 12:00 GMT
The problem is more serious than it looks like.
If the repeated track is short enough - for example the short Buddha Machine loops (http://www.fm3buddhamachine.com/site/?page_id=29) compressed using FLAC - Rockbox buffers its maximum number of tracks (32) and after every one repeat of the track it buffers the track again and again...! When playing a 8 seconds long loop the disk spins up and down every 8 seconds.

Loading...