FS#6525 - LCD Backlight Setting "off" for "on hold key" is incorrect

Attached to Project: Rockbox
Opened by Alonea (rdhddmazoku) - Wednesday, 10 January 2007, 22:59 GMT
Last edited by Steve Gotthardt (gotthardt) - Friday, 12 January 2007, 09:58 GMT
Task Type Bugs
Category LCD
Status Closed
Assigned To Steve Gotthardt (gotthardt)
Operating System Gigabeat F/X
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Ok, If I understand it right, "normal" refers to whatever the other backlight settings are and to use them, "on" would mean when you flick the hold switch the light will stay on regardless of other settings and if its set to "off" when you flick the switch the light will go off regardless of other settings. Normal and On work like they should, but off does not. It acts exactly like normal does when it should actually turn off the light.
This task depends upon

Closed by  Steve Gotthardt (gotthardt)
Friday, 12 January 2007, 10:03 GMT
Reason for closing:  Not a Bug
Additional comments about closing:  Built from latest SVN
Comment by Steve Gotthardt (gotthardt) - Friday, 12 January 2007, 10:02 GMT
reopend to add comments:
In 'off' the backlight will not come back on while the hold switch is on. This can be tested by enabling caption backlight. When the song reaches the end, the backlight will not come on to show the song caption as it does in normal.